Error commandline render [close]

./SynfigStudio-1.3.13-testing-2020.03.14-linux64-7816d.appimage -i e11t12.sifz -o dir/w.png

synfig(17876) [15:27:21] información: Render split to 1 block 781 pixels tall, and a final block 299 pixels tall
./bin// línea 66: 17876 Violación de segmento  "$BASE_DIR/bin/synfig" "$@"

In a lot of projects happens this

/home/fuquo/4232/escena_11/toma_8/e11t8.sif ==> /home/fuquo/4232/escena_11/toma_8/e11t8.sif.dir/w.png: Frame 12 of 251 (4%). Remaining time: 1h 28m 46s synfig(25113) [19:18:29] error: png_mptr: error: IDAT: CRC error

Thanks for reporting. I will take a look.

1 Like

version 3.5 and 3.12
2020-03-23-112523_155x130_scrot 2020-03-23-112547_183x192_scrot

Other problems of render with bones and type of layer

The same problem with GUI application or just by command line?

No the gui works quite well.
The problem is when doing a render

find . -iname "*png" -exec pngcheck {} \;
OK: ./cara.png (4470x2451, 32-bit RGB+alpha, non-interlaced, 99.8%).
OK: ./toma8_fija.png (1280x720, 32-bit RGB+alpha, non-interlaced, 93.2%).
OK: ./cielo.png (2980x1634, 24-bit RGB, non-interlaced, 85.5%).
OK: ./bg.png (2980x1634, 32-bit RGB+alpha, non-interlaced, 65.6%).

i check png

Can you please try this? -

./SynfigStudio-1.3.13-testing-2020.03.14-linux64-7816d.appimage -w 480 -h 270 -i e11t12.sifz -o dir/w.png

This works well…

It is a problem by memory RAM ?

1 Like

i try with ppm or tif but it gives back same error

Yes, this could be problem with system not having enough RAM. Can you please launch a system monitor (to see RAM consumption) and start rendering?

BTW, what is the resolution set in e11t12.sifz file? :slight_smile:

@bazza How much RAM do you have on your workstation? I can try to render on my PC with 16 GB of RAM, to see if crash persists. :slight_smile:

1920 x 1080

This before walked… No that it can have changed

synfig 9483 fuquo mem REG 0,44 299920 58 /tmp/.mount_wGH1x5/usr/lib/

This using the libpng of the appimage. only I have this problem?

Finally it was a png broken that pngcheck do not detect like error

1 Like

Great, happy to know the issue is solved. :slight_smile:

1 Like