Development snapshots for 0.64.1 **Bones branch included**


#21

well, i’m working under Windows XP SP3, it may not be a stable package but i’m going to test it because i’m really impatient, also i have good luck breaking testing software so if i find anything strange and is not listed i’ll let you know, thank you all


#22

Hi!
Maybe it is my imagination but I see it faster (double faster) rendering Mcwolfen example file. :open_mouth: :open_mouth:
EDIT: Nope. It is more or less (more less than more) the same than before with Software.

Apart of mentioned problems in your post I’ve seen one additional issue.

The gamma tab is not rendered correctly and when selecting the tab a bunch of messages appears.
Using windows XP 32 bits here
-G
synfig-0.64.0-winxp-gammatab.jpg
synfig-0.64.0-winxp-gammatab2.jpg


#23

Hello:
Before i tried to build synfig for windows using the instructions in the wiki but i failed.

Now I’ve downloaded the version of Zelgadis from the drpbx link.
I’m using rigth now.

I have the same problem that darkspace65. Resizing the canvas window hangs synfig. Even hangs all the Win7 system. So I pressed the win button (the one with the icon), to chenge to other open aplication, then returned to synfig; the hang disapears.

Also, First i tried to add a TEXT layer. Another hang, so changed of aplication and wait. After a moment the hang disapears.

But I think that maybe this is not the right topic to talk about this building?. Maybe I think move this to other thread.

Just to be clear: Does this win version have a bones layer, or plugin? Where can I find that?

Thanks for your work! (Genete, Zelgadis, PixelGeek, etc).


#24

I messed around with the .64 version with the windows version a little, and I like the change of speed =)) good job You guys =p. I’ll be greatful when the final version comes out!

One little thing I noticed (not to criticize your hard work) that I don’t think I can do again. I opened 2 projects, then closed one while the other was still loading. The one that was still loading stoped with empty squares in them, and synfig locked up.


#25

Thank you everyone for feedback. This week will be busy for me, I will try to work on the spotted issues after June 10th. Thank you for patience! :slight_smile:


#26

Also, If you have labeled keyframes, it glitches on the canvas if you move around on the navigator, or when you scroll.


#27

I had a stab at using the fedora build script, but I think I need a few more pieces than the script installs… It failed when failing to find autoreconf. I installed automake, autoconf and libtool, but now I’m getting failures with libtool trying to copy files from usr/share/libtool/libltdl which don’t exist.


#28

Hi, Pixelgeek!

Sorry, I haven’t included all dependencies into script yet.

First of all, ensure that you have all your system up to date:

yum update

Then try to install those packages:

yum install intltool gcc-c++ autoconf automake libtool libtool-ltdl-devel

I hope that will help.

BTW, can you please share your .nsi file for creating Synfig install bundle? I have mine, but maybe I can borrow some options from yours… :slight_smile:


#29

How about a layer bind option? Then we can bind just any layer, not only images but effects and such as well.

Point binding would still be used and overrides layer binds. You can first bind the whole layer and then set influences on individual points as well.


#30

Hello:
You are going to hate me, but I have to say it:
This skeleton-bone layer implementation is wrong. It’s very difficult: to understand, to work with it… At least from my point of view.

In Blender, or years ago, in Moho, (I haven’t used Flash… yet) you first create the bones and later “link” the group of vertex to the bone. But you are doing backwards. And even worst, vertex by vertex, generating a lot of bones, that may get useless, and I can’t see a rapid way of deleting that useless bones.

And I’m suspecting that the guilt is Synfig-gui. It’s too complicated. :angry:

I imagine this way: selecting several vertex from a region layer, right-click: it appears an option, “link to bone…”, and then choose the bone to be linked.

On the other hand, the representation of the bone is ok… I suppose.

You are doing a great effort, but in the wrong direction, i think.


#31

The current workflow is the result of lack of user interface to create bones properly (bone tool) or to assign points to bones (bone bind tool). When this core behavior was implemented, that ugly interface was the only easy interface available (create bones via insert item) and so it takes its consequences. The fact that bones are not deletable is not an issue. It has not been coded to delete a bone yet (delete a bone needs to detach it from its parent and make its children root bones - or whatever decision the user want to do with the children bone(s)-).

Also there are missing tools like reparenting bones, or change bone strength.

Remember that this is the implementation of the core system, not the final design.
-G


#32

Hello Genete:
Thanks for your answer, and sorry if I was rude.

However, I still believe that synfig might be easier.

I really hope I could colaborate with the project, in some way.

And again, thanks for your work, and the work of the other members of the team.


#33

Absolutely not! Current bones user interface is awful! :wink:
-G


#34

Here’s the thread for those who want to follow the progress of my work on Windows binaries - http://synfig.org/forums/viewtopic.php?f=13&t=4379.


#35

Hi again! How’s the development been going?

Quick question: How’s the current development snapshot compared to the previous stable? That’s because the stable version I’m using still crashes on me, especially when scrobbling through timeline with multiple gradient blend modes…


#36

Just be warned - the current development snapshot have one nasty bug - synfig.org/issues/thebuggeni … issues/461


#37

I’m at an early stage of testing so I haven’t got anything repeatable yet, but I’ve come across some minor bugs in the latest 0.64.1 test binary. I’m using the x64 RPM on Fedora 19 KDE.

In particular I’ve noticed on crashes, the recovery isn’t working properly - I’m getting “Document Is Not Well Formed” errors that I’ve never experienced before. As moving the timeline in the Canvas window is very crashy using the software renderer and crash recovery is vital to stop this being too much of a problem.

I’ve also got “ghost” objects appearing twice - duplicate object layers that I did not create. I’ve had two duplicate Star layers appear now that I didn’t create.

I know these anecdotes aren’t very useful for you so I’ll try and get a sequence of steps together to make these repeatable for you.

The new parameter interpolation is working perfectly for me - it’s a lovely new feature and already I wouldn’t be without it.


#38

Can you confirm the binary that you’re currently using? This thread is for a outdated development snapshot version.
Cheers!
-G


#39

Sorry Carlos - I’m using

Development version:
Revision: 20130826
Branch: master
Revision ID: 034175

Built on Aug 26 2013


#40

This is something I’ve been seeing sometimes when I re-open this dev version of Synfig Studio after I’ve had crashes:

snapshot1.png