Dependency issue for libtiff-dev & libpng-dev when building on Debian Strech/Sid


#1

Linux Autobuild on Debian Strech/Sid has some issue with the libtiff-dev & libpng-dev dependency:

Package libtiff-dev is a virtual package provided by:
  libtiff5-dev 4.0.7-5
  libtiff4-dev 3.9.6-11+deb7u3
You should explicitly select one to install.

and

The following packages have unmet dependencies:
 libpng-dev : Conflicts: libpng12-0-dev
              Conflicts: libpng12-dev but 1.2.50-2+deb8u3 is to be installed
              Conflicts: libpng3-dev
              Recommends: libpng-tools but it is not going to be installed
 libpng12-dev : Conflicts: libpng-dev

#2

Possible fix:
github.com/synfig/synfig/pull/328