Corrupt Mac dmg ?

I’m not sure if this is the right place for this, but it was my best guess . . . anyway…

Yes, I’m a new forum member here, and I have attacked the learning curve with the 1.2.0 version for MAC.
Actually, I am moving right along, however I got an email notice that a new development version (1.3.3) was available and that I could try it if I wanted to.

Unfortunately, the d’Loaded disk Image (.dmg) seems to be corrupted and after trying 2 times, I thought I might mention it somewhere.

When I try to open (verify) the dmg it shows an error on verify.
I’ll try to upload it here.

Corrupt DMG Image Data.png

Hello ArtCraft! Thank you for reporting! Did you got DMG package from … -20170430/ ?

It appears I got it from the SourceForge site.
From the get Info page;

", … g/download


I have compared checksum of the file on server with my local somy and they are identical.

Can you please post md5sum of your downloaded DMG file here?

(just ropen console/terminal and type “md5sum /path/to/your/dmgfile”)

Well, In my Terminal, I tried the commands you suggested and all I get is ‘command not found’
I run a (default) bash shell in my Terminal here, and even after a search (using locate md5sum), the only results I get is that ‘md5sum’ may exist in a zsh shell here, which, I would have a lot of trouble with trying to switch shells, as I am not experienced enough with that, but I think it could be done. I just don’t feel that comfortable on the command line and don’t use it enough.
I will check on my Mac forums and try to find a way to get that checksum value for you.
EDIT 10 minutes later; the proper command for me is just md5 /path to file and the following is what I got;
Desktop/synfigstudio-1.3.3-20170430.dmg) = 4ae3e86dea6c9bc55e6d9f56af9a545e

However, here are some NEW developments at my end !

I went back to the SourceForge site and downloaded the 1.3.2 version in stead, and managed to get it installed and working. It took quite a while before it popped open, but there it was. New splash screen and all.
It seems to be functioning, but since I am still learning how to even use Synfig, it may be a while until I see if it’s OK or not, but I will try to report anything that may be important if it breaks.

ALSO, In the process of installing vs. 1.3.2, when I check the internal vs. number where it says ‘About Synfig Studio’ it says it’s vs. 1.3.1 ( Revision 20170202, ID 30c218) !!! and this seems a bit strange . . . perhaps not that big of a deal… whatever…

AND, there’s one more thing too.

After installing vs. 1.3.3 My Synfig version 1.2.0 has now become unusable, and it reports being corrupted.
I still have the DMG for 1.2.0, so I could reinstall it if need be.
Is this a normal situation ?
Perhaps there is a plist file that they share, which should be deleted before switching versions ?

Have any other Mac users been using vs. 1.3.3 here successfully ?

Thanks for your assistance.

I have the same checksum, so the files are identical. I will verify my local file - maybe it was corrupted during transfer from one host to another.

Please try to copy into your Application folder and start from there -this should speed up the process.

If you get “SynfigStudio can’t be opened because it comes from a non identified developer” error, then you can solve this in the following way:
Please go to System Preferences > Security and privacy. Press the “Open anyway” button.

This is weird. Please try to reboot your mac and try to start 1.2.0 again.

Hello again! I have re-uploaded the correct version (both to Gumroad and SourceForge). Please check if it works for you now - … -20170430/

Re-Booting did not change anything here.
The 1.3.3 version I had, still did not get through the verify process and it never got installed here.

However, I see that you posted another version before I posted this reply.

I have downloaded the new version and YES! it does get through the final verify process and indeed (after an initial 3-4 minute wait) popped open and it is indeed vs. 1.3.3 inside using ‘about’.

Just to be sure/safe, I closed it down, and restarted it again and it popped right open, with no wait at all.
It reminds me of when I opened Gimp for the 1st time and it has to initialize the fonts ?, which takes a while? and is typical.

Note; I had re-installed the stable 1.2.0 version temporarily, and I noticed that the strange occurrence of getting damage to previous versions does not happen anymore.

So, good, and thank you .
I will give 1.3.3 a good work-out and report any problems I run into.

Great, I am happy we got this sorted out. Thanks for reporting! :slight_smile: