Constant animation speed


#1

Hi there,

I’m new to Synfig & could do with some help.

I’ve created a simple animation: two key frames, with objects simply scaling up and rotating between the two.

The total animation is 48fr @24fps

Now, for some reason the finished animation will not run at a constant speed - the objects all speed up and slow down (at the same time and rate) between the two key frames. It’s a cool effect, but not what I’m looking for.

The only things I’ve done are change the Angle and Scale parameters on the second key frame.

Any help or suggestions would be very gratefully received!

EDITED TO INCLUDE EXAMPLES:

Screen shot of work area
Animation


#2

NB. I did not seem to have this issue on a shorter animation I did (half the length). But it’s possible that the speed variation was just less noticeable, I suppose.


#3

You might want to look at linear interpolation between waypoints. I guess your default interpolation is not set to linear, hence you are facing this problem. So just right click on the waypoints that you want to change and set there interpolation type as linear.
BTW it is always good to provide an example animation file regarding your problem.


#4

Thank you, I’ll give that a try.

And you’re absolutely right, of course - I just had to step away from my laptop in frustration, I wrote this from my phone :slight_smile:


#5

So I think I did what was suggested, my waypoints are now set as linear (in and out), but the issue seems to be persisting:

Screen shot

Animation

The animation seems to start quickly and then slow on each loop (the animation is one 90 degree turn for each layer)


#6

Hi! I can see now the first keyframe with linear interpolation but not the last one. Can you share your project file to try to figure it out what its going on?


#7

Hi ebarranko.

Yeah, I noticed there didn’t seem to be any way points on the last key frame. I’m genuinely not sure why that is…

Is there a preferred way of sharing files on here?


#8

You can upload files in your post but you need to earn the Basic badge that comes with a minimum forum’s participation and read the guidelines. You can use dropbox or Drive or whatever other service you use, doesn’t matter.


#9

Thanks @ebarranko

Try a We Transfer of the project.

I’ve found with a little bit of playing, that animating groups of layers doesn’t seem to generate a waypoint on the last keyframe.

I don’t know whether anyone else has found this to be true??


#10

No, it’s alright everything is working fine I can see your problem now. Give Me a moment and I’ll make you a video to show you. :slightly_smiling_face:


#11

I hope this is useful:


#12

Thank yo so much - you’re a hero!

I didn’t think that the display would actually hide the waypoints from me! :slight_smile:


#13

Me neither, whenever I tried to do a looping animation I always set my time bigger that my actual animation and add a time loop layer to test it, I never have had this problem. :sweat_smile:


#14

So, the plot thickens…

I did exactly as you suggested, lengthened my timeline so I could see my last keyframe and way points. I ended up rebuilding the animation, with default interpolation set to Linear. Everything as it should be.

To start with I only animated the rotation, to make sure it was working. All good

Then I implemented the scaling animation and it all went wrong again :sweat_smile:

So I decided to try just scaling, with no rotation. Again, all way points accounted for, all on Linear Interpolation - the only thing I changed was the scaling of the layer groups here. and this was the result.

Something weird is going on with the scaling. You can see the animation slow down.

Project with just scaling here, if anyone would like to take a look and help solve this riddle! :sweat_smile:


#15

You right! I’m going to test it with other versions of Synfig maybe it is a bug.


#17

I thought a little more about this and perhaps it’s just an animation problem after all. I tried another software with the same result so I was thinking in a 3d solution for a 2d problem and of course that is a mistake. I show you here:


#18

That makes a lot of sense, actually! …I think… :sweat_smile:

Thank you for putting so much time and thought into this - I’ll have a play with it and see if I can replicate it.


#19

Well, you’re right, it worked!

Finally, a Finished amimation!