Cant use seconds

duration
canvas
units

#1

Hi,

I am new here and maybe will look like a complete noob but there is one thing i cant seem to solve (maybe i just need some library)?

Anyway, the problem is that when i follow the animation tutorial, in the properties for said animation i cant set the “Begin time” to seconds (when i do that it will change to frames) and i get an error in the command prompt, something about it not being able to recognize the letter “s” and that it assumes frames instead.


#2

Hmmm,
can you please take a screenshot of the render dialog just before you press enter (just after have been written your time in seconds)?
In any case, you can enter time in the format you want (if recognized) that it would always display it with the format defined by the user in the File>Settings>Misc dialog tab.
Also, full read of the console message would help too.
-G


#3

Same here.
I’ve been trying to use synfig for about 5 minutes.
Following wiki.synfig.org/Doc:Animation_Basics.

The very first task from the official basics tutorial fails.
Changing the End Time (frames) to the value 2s (seconds) fails.
I’m sure this happens for some reason, but the point is, that I am explicitly told to do so and I have no previous knowledge.

This is the worst user experience I can imagine.


#4

HEllo an0ying , welcome here.

But, did you come to get help or just be funny ?

  • First 5min for a new software, in a no explicit domain (“art with math” aka spline and co), with his own way of doing things (not a X or Y clone) … it’s more consuming than exploring. Did you gave just 5mins on for example photoshop/after effect/… before doing cool with it ? … etc etc …

  • Do you want to progress and solve your problem ? help us to help you… describe what you did, what you get …


#5

I did come here to share this experience so somebody at the right position might know what actually is the problem and fix it.

There is not even a File -> Preferences menu.
It is Edit -> Preferences.
I’m sorry if this seems funny to you or trolling, but this is exactly the kind of “basic details” which put false information into a beginners tutorial.

Edit -> Preferences -> Misc -> Timestamp is set to FFf if that is the information you wanted to know.

As I said, I just followed the very first step from basic tutorial linked above.

Edit: I’m using Synfig 1.0.2 in case the preferences menu switched places from some previous version.

I changed the timestamp to (HHh MMm SSs) FFf and it is working, I’ll go on from here…thanks for the quick reply.

May I add this information as “Step 1” to the basic tutorial?


#6

good to know that working has you expect…

Yes with pleasure, you are welcome… ! What do you think about something in the mood of : “…that will make our animation 2 seconds long. Good to know, synfigstudio can display the time in various format (timestamp), and you can configure it in Preferences.”

If you note another beginner things… synfig need those kind of report.

sorry my side, i was kind of direct/brusque … “human relation screens in between”.

enjoy your synfig discover,
see’ya


#7

Hi!
I updated the wiki and added a link to the info about the various Timestamps in the Setting Up The Workspace part of the tutorial. Also added the setting to make it show seconds in Endtime tab. I noticed the discrepancy in the tutorial when I changed the pictures a while ago, but due to health problems and more comic related work, I forgot to change it.
Getting the wiki updated with the current development of Synfig Studio is a large and ongoing process. Any help from beginners is welcome.
Greetz!


#8

In Synfig Studio 1.2.2, the Preferences dialog doesn’t seem to have a “Misc” tab any more. How does one change the unit for timestamps now?

EDIT: It’s on the “System” tab, not sure how I missed that. Now, why do all these options start with hours, when all I want is seconds? Shouldn’t there be a way to just display the largest extent that’s involved in my canvas (ie. don’t show minutes unless there’s more than 60 seconds, don’t show hours unless there’re more than 60 minutes)?


#9

You need to select this -


#10

@ stuartpb

Please refer to the Wiki https://wiki.synfig.org/ and avoid necroposting :wink:
Things have changed a lot in 3 years

Closing this thread