Can't duplicate keyframes and waypoints duplicate incorrectly

Hi,

I’ve spent weeks creating a character and doing all of the key poses for him talking. What I had been doing was creating keyframes for each pose, each of them 12 frames apart. When I wanted to create a new frame, I’d often duplicate one of these keyframes to make it easier to work from a similar key pose (for instance, animating the mouth shape of an “oh” to an “oo” lip shape). Well now I can’t duplicate anything at all. I’ll set the marker for the newest key frame in the timeline (we’ll say frame 162) and then I’ll go to the keyframe menu and select frame 12 and hit “duplicate”…and nothing happens. It doesn’t matter if I try to duplicate this same frame into a different part of the timeline, or to try to duplicate a different pre-existing frame.

Also, to try to get around this, when I try to duplicate waypoints, some of the layers duplicate, and others are screwed up. For instance, if I want to duplicate frame 12 to frame 162, everything in frame 162 looks normal but the chin is all of a sudden in a different place. When I right click on either one of the key frames–either frame 12 or frame 162–both of them say they have 189 waypoints; the same amount. I’ve tried to duplicate just the chin itself to the new frame and have the same exact issue. If I try to duplicate it to an earlier frame, the chin is still in the wrong place, but not in the same wrong place as the latter frame. Tried both in animate and non-animate mode and have exact same results. I really don’t know what’s going on or where to go from here. I have never had this problem before.

So my questions become:

  1. What could have caused the inability to duplicate frames? Of course, the ability to duplicate keyframes is absolutely essential, so preventing this from happening in the first place is absolutely crucial–even traditional animation reuses frames.

  2. Why are the waypoints duplicating inaccurately, and how can this be prevented?

  3. How can each of these problems be fixed?

Hope someone has any ideas as I’d be truly grateful after spending all night and day getting absolutely nothing done with this project except getting a headache and blurred vision. Thanks in advance.

Hi,

I’ve never experienced such problem with my animations and I use duplicate functionality A LOT (both keyframes and separate waypoints). Can you, somehow, reproduce it in a clear project with the same layer types/actions? This would help to nail down the problem.

If not, I can only ask you to upload your project somewhere, so we can investigate it. Without the file it’s hard to tell what’s going on in there…

Also, do you have grey waypoints on your timeline?

Hi,

Thanks for your interest in this issue. Sorry it took me so long to reply. It’s been a busy week or so.

What I ultimately ended up doing was copying each layer into a new project. I had to relabel all the keyframes (if there is a way to copy and paste the keyframe panel, that would be really cool, but I don’t know about it if it exists). My keyframes and waypoints were then duplicating as normal in this new project afterwards. The original project still has the same issues, and I still haven’t found the cause.

Some food for thought though: I was originally working with some exported canvases prior to this. I can’t remember exactly what I was doing. I recall that there were a couple times I copied and pasted layers into new projects that didn’t contain said exported canvases. There is a possibility I might have copied and pasted the layers into the new project and that any editing done on the older exported canvases may not have gone into the new projects? Maybe when I tried moving keyframes around, Synfig showed that there were keyframes there but they didn’t reference to anything because they were linked to the old exported canvases? I’m not too sure. I have yet to test this, which I think I will, because that might have been a mistake that I made and one worth learning by. It’s just been many weeks and so many steps along the way that I can’t remember the cause for everything, but I know I had exported canvases originally that are not there now. There may be someone out there laughing and saying, “That must have been it!”

Unless anyone can affirm my speculation, I’ll let you know what I find out. I’ll probably go ahead and test it anyway because it will only take 5 minutes to try to duplicate the issue (if this was the issue) and I’ll let you all know. It drives me crazy not knowing where I goofed because the anxiety of repeating my mistakes will linger until I know how to prevent them.

Thanks again.