Can't draw things

— Synfig report beginning —

Version: 0.62.02
Linux info: openSuSE 11.3, kernel 2.6.31


I can’t draw things in animation. They’re in the tree, however inside animation window they’re not appear. My older, “training” projects opening good (all is shown). What is the problem?

Console output:


synfig studio – starting up application…

synfig(22637) [04:55:06] info: Loading modules from /etc/synfig_modules.cfg
Quit Request
synfig(22637) [04:55:30] error: KeyframeActionManager::refresh(): Not ready!
synfig(22637) [04:55:30] error: KeyframeActionManager::refresh(): Not ready!
Quit Request sent
synfig(22637) [04:55:30] info: DockManager::unregister_dockable(): “pal_edit” has been Unregistered
Application appears to have terminated successfully[/code]

— Synfig report ends —

Run Synfig Studio. Go to Toolbox and at the bottom of it there is a drop down box to select the “Default Blend Method” for new layers. Check that you have “Composite” selected and not “Straight”. Try again and you’ll see the layer’s results in the canvas.

It’s set to Composite - that’s the reason it’s so strange.

Can you create one file with some of those invisible layers and paste it here?

OK, here you go:
invisible offender.sifz (488 Bytes)

As I said older animations open correctly.

You have problems with the input devices. It seems that you are using a tablet or that you have missconfigured the device settings. Please double check that the Device Settings dialog shows none of the devices enabled and then try out again.
Please, also confirm that you’re using the latest version because that device input problem was solved at Synfig 0.62.00.

If the problem persists please report the computer specifications to check what’s the cause of the problem.

Hey, I don’t have tablet at all! I used pure mouse to draw things. And I have newest Synfig available in openSuSE repo (installed via YaST)

//edit: And I use 0.62.02 not 0.62.00.

Wow, those Suse guys are really quick! I just released 0.62.02 four days ago!

In that case, can you remove the .synfig folder form your user folder and start over?

I’ll try, but now upgrading synfig to -pm1.2 and I am bit afradi to do it now. But when Yast will finish, I’ll do it.

//edit: It helped, but not sure if it was updating or deleting .synfig. Anyway, thanks for help! Now I only need to learn how to use blend modes properly…