Can't draw anything - fixed

for some reason, synfig is not allowing me to draw anything. whats wrong with synfig?

Try to disable all the input devices in the device settings dialog in the Toolbox File Menu. After that try to draw things again.
If that doesn’t work please provide Synfig version, operating system and full hardware details.

Still doesn’t work. Not even for me. It’s funny because I used Synfig to try out the Metaballs and it worked great, but suddenly it’s not even listening to me. o_o It won’t let me draw, won’t use the mouse wheel to zoom in and out, but from the outside it just looks “fine” and doesn’t crash. When I use the bline tool I can’t see anything. When I use the Star tool, I STILL can’t see anything but the layer exists!

I tried to disable everything in the Input Devices menu, and even tried reinstalling 0.62. And it still doesn’t help.

Have you got any device plugged in?
Can you show the names of the devices in the device settings?
Did you save the device settings?
Can you check the layer origin’s values and modify it to actually see the layer?

Okay I think the problem started when I either

  1. installed all heck applications with apt-get when I plugged my PC into a cafe internet, or
  2. When I started Ubuntu with my Genius Tablet plugged in last night.
  3. I installed WINDOWS Genius drivers last night accidentally (and it doesn’t ask for confirmation) in Ubuntu Wine.

I tried removing the tablet and checked, but still not working. I don’t know how to uninstall Wine apps, so I just deleted the folder of the drivers and it still doesn’t work. I tried saving the device settings, but I’m not too sure if it’s even working (the Input Device menu, I mean; I click on “save” but nothing happens. I assume the menu’s supposed to be like that, so I just move on). I tried changing the Origins values but that doesn’t help either. The Bline too also just doesn’t work.

UPDATE: Nevermind, all of a sudden it’s just fixed. I don’t know how but it just randomly happened (I’m confused). Thanks for the help, by the way. I think it was the Input Devices thing.

For us is very difficult to reproduce a problem that lies on hardware. I’ve tested build and install Synfig in a virtual machine with Ubuntu 9.10 and the only problems I had was the mentioned in this thread: viewtopic.php?f=13&t=972