Camera widget

Synfig has not a camera support. I’ve arranged a workaround to have a camera fake using logarithm convert type and the zoom layer.
Notice that you’ll need to have minimum the revision svn r

Just download the attached file and render it with and without the zoom layer enabled. Dig it to know how I did it and ask here if have doubts. Play with the Circle layer called “Camera widget” to move the camera zoom and position. The red rectangle represents the visible area.

Latest camera widget version and usage instrcutions here: viewtopic.php?p=1829#p1829
camera.sifz (2.24 KB)

Hey, it works great! :smiley:

But there’s a little drawback: the visible area (on the video) must have the same height/width ratio than the whole canvas.
So, it’s not possible to make tracking shot effects (with a 200 × 2000px background for example) without having a y × y×10 final render.


Hey, here’s my little improvement to camera widget:

  • Red semi-transparent circle which controls the camera now stays at the center of the view area
  • Use the “camera view” checkbox on Chlidren Panel to switch the camera view on and off


  • Camera rotation
  • Changing camera region to correspond non-standart document sizes
    camera-view-0.1.sifz (2.29 KB)

Here’s new version of camera widget with rotation support!
camera-view-0.2.sifz (2.48 KB)

I like it.
Just two comments

I prefer the star to have only two peaks instead of 12. It is more easy to see quickly how much did I rotate. Also to make less confusing to the user and to produce better shape of the star camera, I’ve set the Scalar of the outer radius of the star to be -1.0. It makes the inner radius to be the outer of the star and hides the inner one below the origin
It produces a more readable camera widget in my opinion.


Cool! I agree. Could you upload sifz here?

is it possible to transfer value base nodes from one synfig document to another? i’m asking because i’m trying to get the camera widget to work in my ninja animation…i edited it to fit what i needed in my own animation fine, but when i copy and paste the camera widget layers to my ninja animation, it doesn’t copy the value base nodes as well, so its not possible for me to turn on and off the camera view, since the parameter wasn’t transfered from one sifz file to the other! :confused:

Thanks to all honest replies!



No, not possible by now. You have to open the imported file in its own window and edit the value node there. The effects would be transfered to every file that imports that camera widget. Of course you can have multiple copies of the camera widget file for each project, so when you edit one doesn’t modify others.

Also you can do the reverse: In a copy of the camera widget import your animation and use it as the final animation file.


hmm…that’s what i kind of figured! :frowning: its too bad synfig doesn’t allow u to copy the nodes from one sifz file to another, as that would certainly make it much easier for me! oh well! i guess i’ll do what u suggested then! i’ll just copy the ninja animation layers into the camera sifz file, and use it for the final animation! of course that means i’ll lose the value base nodes in my ninja animation, so i wont be able to rotate any layers in it… :frowning:

I wish synfig had a better solution, but thanks anyway!



Coolname - not cut and paste!
Import your sifz file intact.

:open_mouth: :open_mouth: :open_mouth: :open_mouth: then why can’t i just import the camera sifz file into my ninja animation file then??? it seems like that would make more sense then doing it the other way, i.e. importing the ninja animation file into the camera sifz file!

Looking forward to ur reply…



One solution or the other obligates you to open each file (importer and imported) in its own window to be able to edit each value node exported parameters (as I mentioned in the previous post). You decide. The result is the same, two windows opened. You can check how I did in my rocket animation for November challenge.

right…just one problem! what if i wanted (which i do) to change one of the value base nodes (the camera view one) so that it would be in camera view in one keyframe, for example, but wouldn’t be in camera view in the other??? :confused: how would that be done, if u have to first edit the value base nodes before importing into the desired sifz file, and what i just wanted to do is change back and forth from camera view in my ninja animation? :wink:

Looking forward to ur next reply…



i would check, if i didn’t have just one tiny little problem…my computer wont boot into ubuntu any more (remember i said before that the rocket animation doesn’t work in Vista, for some reason, and so even though i have it in ubuntu, and it works, i wont be ably to check it until i fix it!) because i get some kind of error, that says the following: “crc error” and then on the next line “system halted”! :unamused:

Does anyone on the synfig forum have any idea what could be the problem??? or perhaps have run into it with ubuntu 8.10 themselves??? i used wubi-installer, by the way to install ubuntu 8.10 on top of my pre-installed OS!

Thanks to all honest replies! :wink:



EDIT: oh! and one more thing, before Genete tells me to…i’ve already posted this problem on the ubuntu forums, but have got no real solution to it yet, so i decided to see if anyone here on synfig could help! Thanks in advance! :wink:

I don’t have an answer for that. Maybe due to:

  1. Because I don’t understand what you mean
  2. The answer will be the same than before.

Regarding to wubi I haven’t the reply either because I have less experience (zero) with wubi than you. Certainly, asking at ubuntu forurms/chat would be my chosen option as well as dig further with google.

ok…what i meant is that what i’m trying to do is change the camera view value base node, in my ninja animation, i.e. check and uncheck the box next to that value base node to trigger turning the camera view on and off…but i want to be able to do this in my ninja animation, rather than the camera widget sifz. in order to do that, of course, i would HAVE to have the value base nodes from the CAMERA sifz file TRANSFERRED to my ninja animation file, in order to perform this effect! :unamused: i can say it louder but not clearer! (haha…did u recognize the remark??? :laughing: )

as for the wubi thing…thanks for the google advice! :smiley: funny! the thought of using Google to find the solution to my problem did not even occur to me! now, thanks to u, i’ve Googled “crc error” and “crc error on wubi” and got quite a few returns…although i’m still trying to find someone out there who had the same problem as me, and fixed it! :wink:




Not possible by now.

ok…not trying to be rude when i say this, but…that’s pretty lame! :unamused: how am i supposed to turn on and off the camera view in my ninja animation, if synfig doesn’t allow this option??? and what good is the camera widget to me if i can’t turn it on and off in my animation?

i might as well then just forget completely about the stupid camera widget, then, and try to figure out some other way in synfig to move the view around in a single frame! :unamused:

oh well, then…sorry to have taken up ur time, but it appears as if synfig is of no more use to me… :wink: Just kidding! :laughing: but seriously, someone should come up with a workaround to this, so that value base nodes can be transported from sifz document to document! :wink:

wrong word at the wrong place…

i’m sorry if i offended u with that comment…however i don’t understand how the camera widget is supposed to work if u can’t even turn the camera view on and off in any animation, except in the camera sifz file itself, due to not being able to transfer value base nodes from document to document…and of course, if i do it the other way, and transfer my ninja animation layers into the camera widget file, then i’ll lose the value base nodes in that file…and so i wont be able to rotate layers, or do anything with the layers of my ninja file! :confused:

if i screwed things up with that comment, then i apologize! :frowning: i didn’t mean to offend u!

Best of luck, and i guess i’ll keep my mouth shut (i mean my typing fingers off the keyboard when viewing the forum!) from now on… :frowning: