Built Synfig not rendering in work area


#1

Hi guys,

I’m really liking Synfig and decided to download the source and see if I could help out. I created a Lubuntu 19.10 virtual machine in VirtualBox to use for development with my host Windows 10 64-bit environment on my Acer Helios 300 laptop with an Nvidia GTX 1060 video adapter.

When I install and run Synfig from the package manager, it runs as expected, but when I clone the git repository and build, shapes aren’t rendered in the work area as shown in the following YouTube video:
Built Synfig not rendering in work area

I’ve tried checking out and building previous commits (all the way back to July, I think) and they didn’t work either. Any ideas?


#2

Hi @tortoise!
Woah, I can see a very weird thing from the very beginning -
screenshot_003

  • yellow mark means the rendering of empty frame starts, but hangs.

First time see something like that.
I suspect this could be related with new version of Ubuntu (19.10).
Can you please try with some other version of that distro or Linux Mint?

@ice0 @BobSynfig Maybe someone of you can try to reproduce the same with Ubuntu 19.10 VM?


#3

Hi guys,

I created a Lubuntu 19.04 VM and had the same result. Rendering is hanging.


#4

Hmmm… Please let me know how much memory (RAM) you have configured for VM?


#5

I setup up an Ubuntu 19.04 VM yesterday. I allocated 6 GB of RAM and had the same result. Where would you suggest I set breakpoints to investigate the issue?


#6

I am setting up Lubuntu 19.10 VM to see if I can reproduce the issue…

BTW, do you build “debug” or “production” version?


#7

@tortoise I installed the system and got the same issue here (VirtualBox on Linux). Investigating…


#8

@tortoise I have increased processors count from 1 to 2 and workarea rendering works now.

I submitted an issue about that -


#9

That’s working for me too. Thank you!


#10

Could it be the same problem with Windows version described here ?
As far as I know, Windows release doesn’t use multithread.


#11

@rodolforg I am not sure if that the same problem. As far as I know, Windows version uses multithreading. It was not using in older versions, but after that render engine was rewritten and it uses now.