Building Synfig on Windows (Konstantin's report)


#41

Hi Genete,
Here is the bugged file.
Greetz!
avatar.sifz (29.5 KB)


#42

Ow… :open_mouth: Forgot all about that. I will see what I can do to help complete it.

Greetz!


#43

Using:
Development version:
Revision: 20130620
Branch: crosscompile-win
Revision ID: 993d45

Built on Jun 23 2013

Cairo render enabled, single thread disabled (or enabled):
avatar.jpg

I’ll update with the newest binary to see if it happens.
-G


#44

Update the binary it happens. The issue will be fixed in the currently on revision Cairo render version (not released yet and in progress). In the previous one (the current) the outline renders using the Cairo API when quality is >6 by using a constant width. For some reason the code or the API fails and produce loops when it shouldn’t and lately produce the artifacts you’ve discovered.

I introduced that with the hope that Cairo native API for outlines were faster than the outline render we use by creating a polygon of the outline like a shape. I have found that the speed render time is not appreciable and that there is not benefit to use the native Cairo API for outlines so I removed that render of the outlines for quality >6 using Cairo API by use always the polygon approaching.

Just change the quality to something <=6 and it would render fine.

In the next Cairo render review (0.64.01) it will be fixed.

-G


#45

With the latest binary (build 20130724) I can always reproduce a hang like this:

  1. Open Synfig Studio. Cairo render enabled and Disable single thread.
  2. Be sure that Navigator panel is visible
  3. Press play in Canvas window -> Hang.

If Navigator is not present, it plays fine.

Error not reproducible if:
Software render in canvas (regardless Navigator visibility or render type)
or
Cairo render in canvas but Navigator not visible
or
Single thread is enabled

Error happens only if:
Cairo render in canvas and Navigator is visible (regardless its render method) and Single thread disabled.

-G

EDIT: it happens with the previous binary too 20130620 (I think, because I’m not sure if I un-installed the last one correctly…)


#46

Hi!
I can confirm that bug using Windows 7. Making the Navigator not visible and zoom or pan using ctrl or shift-mousewheel seems to make the system crash less with Single Thread disabled.
Setting vector quality to 6 helped with the distorted vector files. Thanks for that tip. Now I can enjoy the speed of Cairo. :smiley:
Greetz!


#47

Hi!

Conclusions after a day of fiddling with the new windows build.

Cairo works like a charm when setting vector quality to 6 or less. Cairospeed ftw!

Start program, disable Single Thread, resize window, enable Single Thread. Problem solved

Crashes mainly come from open canvas navigator. Hide it and use keys and mouse to zoom and pan if you really want the extra supersonic speed of multiple threads

Happens randomly and since the current file is saved properly it is not a major issue. I mean you wanted to close down the program anywayz…

Removed some leftovers from previous Python 2 installation and both provided scripts work fine now. More then one stickman! Yay!

Nitpicking and not influencing my workflow.

I switched back to the fully English version but will try and spend some time in transifex in the future.

Greetz!


#48

Hi, darkhog!

Thank you for reporting and outlining the final conclusions. It’s sad that you still have the resize bug. Does canvas makes flickering when you resize?

I have no control over the GTK/Windows theme engine. You can try changing your Windows theme settings to fix the issue.

Can you please report this to the bugtracker?

I would like to mention that I do NOT have a goal to resolve all the Windows-related bugs - such ambition would postpone the release of “0.64.0 for windows” to infinity. My goal is to bring the build that is at least not worse than previous 0.63.05. ^___^


#49

Hi!

Russian humor, lol. :laughing:

Yep, it flickers and then it hangs, but not always. I can live with it.

I made Ms Windows my default in the share folder and the problem is solved. Thanks for the tip.

With the overal speed gain, the Cairo setup working and the python script expansion, you won’t see me returning to 63.05. :smiley:

Greetz!


#50

OMG… My deep apologies, that was not intentional. I was thinking about something else, that’s why I confused the username. Sorry. ^_^"


#51

Done!

Sure!

-G


#52

Thank you! :slight_smile:


#53

How is it going?


#54

Hello, everyone!

Here’s another build of Synfig: dl.dropboxusercontent.com/u/155 … 130731.exe

Changes:

  • Uninstall is not brutal anymore.
  • Allow to customize installation (user can choose if he wants to install optional components like ffmpeg and example files).
  • Another attempt to fix resize bug.

Regarding to the last: I have made another attempt to fix resize bug. Please test and report if it’s still there. If the bug isn’t fixed, then I have to dive into advanced debugging.

The problem is that resize bug hangs the system and I cannot switch into IDE to inspect what’s happening (in fact I CAN switch, but, as you know, the resize bug disappears immediately then). So, if my workarounds wouldn’t work, I’m gonna to try the remote debugging. In any case that would be an interesting technique to learn…


#55

Hi!
Thank you for your continuous efforts to make the windows build of Synfig as stable as possible. It’s greatly appreciated. I installed the newest build and for the last half hour I did nothing else then resizing the canvas window, back and forth, big and small, fast and slow. :unamused: Result: no crash, no hang :smiley:. So that’s cool, ha? Install with or without features works. Cairo works fine too. Python plugin works, but returns the canvas window to a smaller size after implementing the script, but I could resize the canvas window without problems. Program crashed after importing an lst.file but that is a Cairo-render problem since the files the lst was referring to were jpegs. After changing the jpegs in the lst.file into png’s importing the lst.file again using Cairo-render worked fine too. Good work. :stuck_out_tongue:
Greetz!


#56

That’s great. Single thread disabled?
-G


#57

Hi!
I tried to reproduce the canvas window resize bug, both with single thread disabled and single thread enabled. No crash, no hang. Everything seemed to work.
Greetz!


#58

Thank you for testing. Please try also to work with complex files. I think resize bug is more likely to appear on big ( = slow) compositions.


#59

Hi!
The biggest and most complex file I currently have is my switchlayer-template and that worked fine. I also fooled around with some banner animations and that went ok too, and I could even do a realtime playback in the canvas window. Something I was never able to do in the past with any other windows version. Only problem I encountered so far is Cairo giving me some troubles with certain lst.files.
Greetz!


#60

Congratulations!
Tested the install options and works fine.
Resize looks to be fixed in Windows XP 32 bits.
Played a few minutes with pirates.sif and didn’t crashed (single thread disabled). It still crashing randomly in other cases, even a simple file, like usual :mrgreen:
With pirates I did -Cairo and Software, single thread disabled:
Zoom in and immediately start to resize the canvas window. I can see the tiles being rendered meanwhile resizing, everything updated with continuous feedback. I repeated this with different zooms, Cairo, Software and nothing, it didn’t hang. :smiley: :smiley: :smiley:
-G