Building Synfig on Windows (Konstantin's report)


#21

Btw, the gamma tab issues can be related to deprecated members for Gdk::GC class.
Just forget about it and let’s fix it using Cairo.
-G


#22

List importer doesn’t work. I had it to when cario was check, and got just an outline. I unchecked it, and did the same thing and got the outline again. At first I thought I was doing something wrong, so I uninstalled the .64 version and got the stable one, and it worked. =p

Gl with the build!


#23

How is it going super excited.


#24

Hello everyone!

Here’s an updated build of Synfig: dl.dropboxusercontent.com/u/155 … 130708.exe

Changes:

  • This is a pure (stable) 0.64.0 version, without unstable additions like bones.
  • I have added a workaround for resize bug. It disables workarea update when user does window resize and “Use single thread” is enabled. When resize is finished the workarea updates. A consecuence of this workaround - workarea does some flickering when you resize a window, but I believe this is better than plain hang.
  • The icons colors are fine now. Possibly, you will not see any change because of the Icon Caching happening in Windows. You need to clear icon cache if you still see old (dark) icons.

I have used this version during my recent workshops and it generally was fine.

New bug discovered during my workshops:

  • If user tries to import PNG image and the image path contains Russian characters then import is failed. I guess that’s true for any non-latin characters. :slight_smile:

#25

Aha! The end of the sound of crickets! :laughing:
Right on time. I was about to start working again on my cut-out template and my character generator.
Might as well do it using this new version to test it out and stretch its limits.
Thanks and good work!

Greetz!


#26

Hi!
Encountered a problem. Opened a file and the new Synfig build distorts the graphics and crashes when I enable the new Cairo render settings. When not using Cairo the build works fine.

Greetz!


#27

Hi!

Synfig seems to crash everytime I use the navigator when Cairo rendering is enabled.

Greetz!


#28

Hi!

Also occurs when I start a new drawing from scratch. Everything works fine without Cairo. When I enable Cairo and use the navigator the program crashes.

Greetz!


#29

How is it going?


#30

I installed the most recent build. Worked on some lst layers, and a number of renders. Cairo crashed in a most extreme way, but the usual render worked well. You’re making good progress. Thanks for working on it and I’m looking forward to the new features of 64. Wish I could help.


#31

Hi!

On most recent windows build I noticed that selected txt in menus disappears. See example.
Cairo disabled in Canvas and navigation and single thread enabled.

Greetz!


#32

Hi!

Never mind, lol. :blush: After changing the contrast of my screen I noticed that the text does not become invisible but just turns white.

Greetz!


#33

It shouldn’t show white text anyway.


#34

Guess what I did? ^___^


#35

I know it! I know it! _o/
-G


#36

You figured out how to make a circle in Synfig? Or… you finished to make a stable windows build. I am hoping for the latter. :laughing:


#37

OK, here it is - dl.dropboxusercontent.com/u/155 … 130724.exe
This version includes multilanguage interface, so Synfig is using the default system language now.

I see the following critical problems to resolve:

  • Correctly uninstall package
  • Add some groups to customize installation (i.e. allow user to choose if he wants to install optional components like ffmpeg, examples, etc).
  • Fix this bug - synfig.org/issues/thebuggeni … issues/459

After that I believe we can officially release Windows build. ^___^


#38

Hi!
Been messing around with the latest windows build that just got posted and made the following conclusions:

  • Cairo works in the sense that it does not crash, but vector graphics still get distorted. (See picture)
  • Still having resize bug when enlarging the canvas when Single thread is enabled. (See picture.)
  • Still having brutal random scrashes when Single thread is disabled.
  • Program crashes after closing it down. (See picture)
  • Synfig hangs when using a python script (See picture)
  • Menu items still turn white and nearly invisible when you select them.
  • I got a partially English/Bad generic Dutch version.

Greetz!





#39

Great to see windows release on the road…

Dutch language is 38% achieved; synfig-core 84% but synfigstudio (ui), 0% ! you can have a look there : transifex.com/projects/p/synfig/


#40

Hi darkspace, thanks for the report.

Can you share the file for that bug? I would like to see if I can reproduce it on other platforms or it is just a windows related bug.
Thanks!
-G