Building Synfig in Qt Creator on Linux Kubuntu

I’ve been having trouble getting Synfig to build in Qt Creator. The project builds successfully using both the Autotools and cmake methods, and Qt Creator sets up the project from the CmakeList.txt just fine. However, building Synfig Studio within the IDE fails at [82%] with the following output:

Check your LADSPA_PATH environment variable.
[ 82%] Generating ../../output/Build/share/synfig/images/splash_screen.png
No LADSPA plugins were found!

Check your LADSPA_PATH environment variable.
No input file provided.
Synfig unknown
Usage: /home/gregory/Synfig_Projects/Synfig_Builds/build-synfig-Desktop-Default/output/Build/bin/synfig [options] ([sif file] [specific options])
make[2]: *** [synfig-studio/images/CMakeFiles/build_images.dir/build.make:1118: output/Build/share/synfig/images/splash_screen.png] Error 10
make[1]: *** [CMakeFiles/Makefile2:1806: synfig-studio/images/CMakeFiles/build_images.dir/all] Error 2
make: *** [Makefile:152: all] Error 2
17:49:46: The process "/usr/bin/cmake" exited with code 2.
Error while building/deploying project synfig-studio (kit: Desktop)
When executing step "CMake Build"

I’ve checked the docs and read this thread, but I haven’t found a solution yet. If there are any suggestions for a fix or even an alternate IDE then I would be grateful.

Operating System: Kubuntu 20.04
Qt Creator v4.11.0

Have you executed script file before configuring the project on QtCreator?

Thanks for the reply.

I did execute, although I don’t remember if it was before configuring the project or not.
I tried deleting the build directory and running Build > Clean_All as well as Clear_CMake_Configuration to double check, but unfortunately I am still getting the same result.

Another thing to note is that the first three lines of the output I posted also show up during the cmake build method, but that still finishes building.

Let me clean build my CMake configured project on QtCreator here to see if I can reproduce your issue.

Mine builds fine without error. I think this might be Kubuntu specific issue.
I use Fedora GNOME so I can’t help here :frowning:

@ice0 Can you please take a look at this?

I set up a Fedora virtual machine to try for myself and it’s just like you said. It looks like a Kubuntu thing.


Hi guys!
I think the problem is that is using a build type other than Debug/Release.

This issue is fixed in this PR. Will be merged soon.


I added a debug configuration and it built successfully! :smile:

Thank you all for your help!