Building on windows


#1

So after i ruled out my minor problems with building and get to the ones that are hardly understandable i decided to create this topic.

Building synfig-core i stuck at this kind of error:

I actually have libjpeg installed, but i tried removing it and whole rebuilding after that and still got the same result.

So here’s my build and errors(actually warnings) logs.
dl.dropbox.com/u/7694232/build.txt
dl.dropbox.com/u/7694232/errors.txt


#2

Ok i’ve been able to pass through the previous, though for now i building without jpg or png support, but it doesn’t matter, i’ll figure that out later.
Though now i’ve got a strange problem when building synfig-studio: With gtkmm-2.4 i’ve got errors about missing header
“gtk/tooltip.h”, because there’s only header “tooltips.h” in my include gtkmm dir. And when i’ve tried to build with gtkmm-3.0 which actually has header named tooltip.h, i’ve got error about some other header missing :frowning:
So can anyone tell me what i’m doing wrong?


#3

Ok sorry for this question, i just didn’t realize that 2.4 is major version, never have any experience with gtk before :slight_smile:
So don’t mind me.


#4

Keep posting your progress. Your jpeg issue sounds awfully familiar. I’m sure I’ve hit this in the past too, but I can’t remember what I did to fix it. I’m searching through old IRC chats (as that’s where I did my brainstorming with Dooglus and Atrus to figure out the Windows build) but so far, not getting any hits.


#5

Predelink, It would be great to correct the wiki recipes meanwhile you’re solving the issues encountered.
-G


#6

I recognized that building synfig-studio without png support is actually useless 'cause it’s trying to make some png out of synfig files during the build.
Getting closer to why AC_CHECK_LIB can’t find my libpng, i’m finding this in config.log:

configure:21291: checking for png_write_row in -lpng
configure:21316: mingw32-g++ -o conftest.exe  -DNDEBUG -O1 -W -Wall -LC:/GTK/lib -DSINGLE_THREADED   -lole32 -no-undefined -Wl,--export-all-symbols -Wl,--subsystem=console -Wl,--enable-runtime-pseudo-reloc conftest.cpp -lpng -lz -LNONE/lib  >&5
mingw32-g++.exe: error: unrecognized option '-no-undefined'
configure:21316: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "Synfig Core"
| #define PACKAGE_TARNAME "synfig"
| #define PACKAGE_VERSION "0.63.04"
| #define PACKAGE_STRING "Synfig Core 0.63.04"
| #define PACKAGE_BUGREPORT "http://sourceforge.net/tracker/?group_id=144022&atid=757416"
| #define PACKAGE_URL ""
| #define PACKAGE "synfig"
| #define VERSION "0.63.04"
| #define LT_SCOPE extern
| #define STDC_HEADERS 1
| #define HAVE_SYS_TYPES_H 1
| #define HAVE_SYS_STAT_H 1
| #define HAVE_STDLIB_H 1
| #define HAVE_STRING_H 1
| #define HAVE_MEMORY_H 1
| #define HAVE_STRINGS_H 1
| #define HAVE_INTTYPES_H 1
| #define HAVE_STDINT_H 1
| #define HAVE_UNISTD_H 1
| #define __EXTENSIONS__ 1
| #define _ALL_SOURCE 1
| #define _GNU_SOURCE 1
| #define _POSIX_PTHREAD_SEMANTICS 1
| #define _TANDEM_SOURCE 1
| #define LT_OBJDIR ".libs/"
| #define WITH_FONTCONFIG /**/
| #define HAVE_OPENEXR /**/
| #define LT_MODULE_EXT ".dll"
| #define LT_MODULE_PATH_VAR "PATH"
| #define LT_DLSEARCH_PATH "/lib:/usr/lib"
| #define HAVE_DECL_CYGWIN_CONV_PATH 0
| #define HAVE_LIBDLLOADER 1
| #define LTDL_DLOPEN_DEPLIBS 1
| #define error_t int
| #define __error_t_defined 1
| #define HAVE_UNISTD_H 1
| #define HAVE_DIRENT_H 1
| #define LT_LIBEXT "a"
| #define LT_LIBPREFIX "lib"
| /* end confdefs.h.  */
| 
| /* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char png_write_row ();
| int
| main ()
| {
| return png_write_row ();
|   ;
|   return 0;
| }
configure:21325: result: no 

I read that ‘-no-undefined’ looks unrecognized for gcc-4.6.x. But looks like libtool treats this as i don’t have corresponding libraries. Didn’t figure out what to do with it for now though.

Yeah, i guess i will do it, when i figure my problems out :slight_smile:


#7

Couldn’t say that i figure out the previous problems, but still after compiling synfig-core i’m getting this kind of error:

After some google searching i found out that doing rebase on msys-1.0.dll could help, but after a few tries (i also tried rebasing some other dlls used by synfig.exe) it still gives me the same error. Rebuilding everything is not helping either. The funny thing - if i run the program using gdb, then it’s working just great :slight_smile:
Actually i’m at loss, don’t know how to fix this thing, if other problems were mostly problem with configuring and can be fixed at least by fixing config-cache myself, this one looks tough :slight_smile:


#8

Uff… i was finally able to build it. It looks like it’s better to stick to gcc 4.5(previous mingw release) and 32-bit system (i’ve build it using virtual machine with 32-bit windows xp). On my native 64-bit windows 7 i keep getting error about cygwin’s heap corruption.
Considering this, looks like not too many changes must be done to current windows build instructions. Though i guess it would be nice to add all the programs and libraries that are essential for building.


#9

Ah - yes. I’m building in a Windows Xp virtual machine under Windows 7. Building directly under Win7 didn’t work for me either. Sorry I didn’t mention that earlier.