building old version in Windows 8


#1

I have no idea what I’m doing. Literally no idea. I don’t even know if ‘building’ is the right word for it.
I have Windows 8, not by choice but by necessity, and because the current version of Synfig is a bit buggy I’d like to go with the older version to see if the bugs are still coming up.

I don’t know how to program, not one line. And only a short time ago, a matter of hours, I learned that Windows OS’s and .tar or .gz files do not get along well. Seems it was made for Unix operating systems. I tried to open the file with 7zip, but this is much more complex that I’d thought it would be.

What can I do here? Is this even building, or can I not see the forest because the trees are in the way?


#2

Direct way (no one tested it on Windows 8 ):

  1. git clone the repository: github.com/synfig/synfig
  2. Read the instructions and do exactly what they say there: github.com/synfig/synfig/blob/m … w-build.sh

Prepare some coffee and enjoy!
-G


#3

I see. Well, I got as far as around line 32 or so before cygwin and frustration got the best of me. It’s a lost cause.


#4

or maybe not… I’m stuck on line 32 of the script in your link, and upon typing the command into the program, this is what comes up-

$ bash /cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 46: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 47: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 52: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 53: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 55: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 63: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: li/…: No such file or directorybuild/synfig/autobuild
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 67: $’\r’: command not found
/cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: line 71: syntax error near unexpected token elif' /cygdrive/c/synfig-build/synfig/autobuild/synfigstudio-cygwin-mingw-build.sh: li'e 71:elif [[ $TOOLCHAIN == “mingw64-x86_64” ]]; then

what does this mean?


#5

Did you edited the script? If so, which text editor did you use?
Is Cygwin installed in the right place?
-G


#6

The script is unedited, Cygwin and the other required program are installed correctly (as near as I can figure), and the instructions were followed as given. I even tried with different variations of the same thing (such as adding or taking off .sh, etc.).


#7

I had the same problem.
This is due to the way GIT is handling end of lines under Windows.
The line ending is CRLF, it should be LF only: $’\r’: command not found is here because of the CR character.
To solve this, you can open it with Notepad++ or any other editor having conversion of line endings feature and save it after change .
Edit -> EOL Conversion -> Convert to UNIX Format

Edit: This can also happen if you execute the git command in the windows console instead of the Git Bash as expected.


#8

Which bugs were so persistent in the 1.0 or 1.1 version that you would want to go thru the windows building hell?
Greetz!