Building 0.62 on Ubuntu 9.04

I was running ./configure on synfig-studio when I got this message:

Unable to set up dependent libraries (synfig >= 0.62.00, ETL >= 0.04.13)

After that, it wouldn’t run make. I tried running sudo ldconfig and then rerunning ./configure, but I ended up with the same message and now can’t get any further. As far as I could tell, etl and synfig built according to plan, but maybe I missed something.

Any guidance would be appreciated.



I started over and it seems to have worked this time: synfig-studio is building now. Not sure what I did wrong the first time.


Well, shoot. The build seems to have failed pretty close to the end:

synfig: error while loading shared libraries: cannot open shared object file: No such file or directory make[2]: *** [128x128/synfig_icon.png] Error 127 make[2]: Leaving directory `/home/dell270/Synfig_dev/Synfig-Studio-0.62.00/synfigstudio-0.62.00/images' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/home/dell270/Synfig_dev/Synfig-Studio-0.62.00/synfigstudio-0.62.00' make: *** [all] Error 2

Again I tried running sudo ldconfig to see if that would help, but no synfig studio was installed.


I had the exact same issue as you. I don’t know what system you are on but for me on Ubuntu 8.10, starting over following this guide helped and Synfig installed properly.

This means that the libraries path is not available. It needs ldconfig to be run from root.

Try this:

Be sure to uninstall the previous versions.
make uninstall at each folder

For ETL:

$./configure $sudo make install $ cd ..

Before make core comment the line “AC_CONFIG_SUBDIRS(libltdl)” in by adding a “#” before.

for core:

$./configure $make > /dev/null $sudo make install > dev/null

Optionally you can use more cores with make -j2 (or -j4 etc). The > /dev/null allows to extract the error messages better.

now do:

$sudo ldconfig

and for studio:

$./configure $make > /dev/null $sudo make install > dev/null

finalize with:

$sudo ldconfig

I’ll try to do a clean installation in a 9.04 and 9.10 machines and post here the results.
Good luck.


These are exactly the steps I followed to build it on Ubuntu 9.04-64, but without all the “> dev/null” , and it worked perfectly.

Ok, I’ve installed Ubuntu 9.04 in a virutual machine (Sun’s VirtualBox):

  1. Download the tarballs: … z/download
  2. Extract them in a folder. Extrat the inner tarballs and extract the tarballs all: ETL, synfig, synfigstudio.
  3. Install the build essentials:
$ sudo apt-get install build-essential
  1. Install ETL

$ cd ETL-0.04.13 $./configure $sudo make install $ cd ..

  1. Install Synfig core

$ sudo apt-get install libxml++2.6-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs libpng12-dev libmng-dev libjpeg62-dev libfreetype6-dev libfontconfig1-dev libopenexr-dev libavcodec-dev libavformat-dev libmagick++-dev libdv-bin ffmpeg imagemagick $ cd synfig-0.62.00 $ sed -i 's/^AC_CONFIG_SUBDIRS/# AC_CONFIG_SUBDIRS/' $./configure $ make $ sudo make install

  1. Install synfistudio

$ sudo apt-get install libgtkmm-2.4-dev libgtk2.0-dev libglibmm-2.4-dev libsigc++-2.0-dev libltdl3-dev libtool gettext cvs ttf-freefont ttf-dejavu ttf-dustin $ cd synfigstudio-0.62.00 $./configure $ sudo ldconfig $ make $ sudo make install

  1. FInalize
$ sudo ldconfig

That should work for an empty Ubuntu 9.04 installation.

Built successfully on Karmic 64 with this method.

(I’ve noticed you forgot a “./configure” in step 4, after the “sed…” line,
also in step 5 you wrote 0.61.09 instead of 0.62.00… )
Nice! :mrgreen:

Thanks! corrected the mistake.

I just tried these steps on Ubuntu 9.10 and Synfig installed, but when I try to draw anything on the stage (circle, rectangle, Bline, etc.) nothing shows up on the stage. The object is listed in the Layers panel as if it has been drawn, but there’s nothing to be seen on stage. I checked the Blend Method and it’s set to the default Composite. During the “sudo make install” step for synfigstudio, I did see a bunch of warnings flash by at the end related to missing modules in imagemagick (I think - they went by so fast), so maybe that has something to do with it.

The older version of Synfig in the Ubuntu repositories for 9.10 does not have this problem.

Any ideas?



Edit - More info:

I just opened an old file and everything in it displays on the stage, but when I try to add a new object, I get the same behavior as above.

I suspect this might be a variation on the input devices problem: bad coordinate settings for input devices can cause objects to be created in random parts of the canvas, far away from the viewpoint. If you create a circle and look at its center coordinates under the param panel and they are abnormally large, you should try changing the input device settings.

Thanks for the info. I enabled my Wacom tablet and it does draw objects on the stage where expected. Objects drawn with the mouse, on the other hand, are in fact way off the stage as you suggested. I can manually correct individual object locations in the Params panel, but I don’t see in the Input Devices panel any place to fix the mouse problem to begin with. Is there any way to do that?

Thanks again,


Try to disble all mouse emulation from the input devices. It should allow use the wacom and also use the system mouse.

I disabled MacIntosh Mouse Button Emulation first with no change, then disabled something called HID 413c:3010 (because it was the only item left other than my Wacom inputs) and now the mouse behaves normally.



Hmmm… Well, something wacky is still going on. Now I can use the mouse as expected and I can draw on the canvas with the Wacom, but I can’t change tools with the Wacom.

After some experimentation, it seems that if I want to use the mouse, I have to disable HID 413c:3010, but then I give up the Wacom. If I want to use the Wacom, I have to enable HID 413c:3010, but then I can’t use the mouse. Weird.


How does Gimp works with the same settings? Can you compare the device settings that Gimp offers and see if there is any difference?

Here is my settings file:
I have all disabled except: Wacom Graphire

input_device.Macintosh mouse button emulation.mode=disabled input_device.USB Optical Mouse.mode=disabled input_device.Wacom Graphire4 4x5.mode=screen input_device.Wacom Graphire4 4x5 cursor.mode=disabled input_device.Wacom Graphire4 4x5 eraser.mode=disabled input_device.Wacom Graphire4 4x5 pad.mode=disabled

and I can use the mouse and my wacom Graphire without conflicts.
It is true that when I have the wacom tablet plugged and all the device settings disabled I cannot use the pen pressure but I can use the left and right click of the pen buttons.
When the device is enabled I can use only the right click button in the pen, but ressure and eraser works fine. (Eraser allows me to select a different tool and settings automatically according to the preferences of the settings file.

I’m on Ubuntu 9.04



Sorry for the late reply, but I finally compared my Gimp settings. With Wacom enabled and HID 413c:3010 disabled in Gimp, I’m able to switch between Wacom and mouse normally with full use of Wacom (e.g., separate tools for stylus and eraser, pressure sensitivity, etc.). So there does seem to be some difference between how Gimp is handling inputs and how Synfig is handling them.

It’s a minor thing, though, so it’s no big deal, but it might be a useful thing for you developers to know. And the big picture is that I successfully built Synfig on Ubuntu 9.10. It seems very stable and, other than the mouse/Wacom thing, all functions seem normal.