Brush tool isn't working?


#1

I have just installed Synfig. I want to draw using the Brush tool. I use the Brush tool and stroke across the canvas. Presumably, this is supposed to make a mark, but it does not. It makes a blank layer, complete with markings like a box and nodes on two corners of it, but no mark where I drew. I noticed there weren’t any brushes in the tool options, so figured that was it. So I installed MyPaint and set the brush folder to the same folder as the MyPaint brush folder. Then suddenly a bunch of brushes appeared. I pick one and try to paint with it, and it does exactly the same thing as before, and doesn’t draw anything. I tried a bunch of different brushes, and it isn’t drawing anything. I can’t figure out how to get this tool to work.

Can anyone help?

I am using Ubuntu, and Synfig Studio 1.0.2.

EDIT: Edited to fix my mistake… I called it the Draw tool, it’s the Brush tool. Whoops.


SYNFIG on Surface Pro 3
#2

Hello Thorjelly and welcome here…

The brush tool is actually in experimental state ( “sorry” the doc/wiki was not clear about that, i have just edited it)
But some basic drawing should work has you can see here .

first point, when you install synfig, you should have a basic brushs set (Concept Design (C_D)" pack by Ramon Miranda.) so nothing in the brush tool options is strange. Could be interresting to understand what’s happen here.

second point, what is checked in wiki.synfig.org/Preferences_Dialog#Render_Tab ?


#3

Yeah I saw that video when I tried to look it up. I was very confused why I didn’t see any brushes, but the brushes that are visible in that video were not there. I had to set it to use MyPaint’s brushes.

Nothing is checked in the Render tab. I tried checking stuff and it seems to make no difference.

I’m not sure if it is a rendering problem. If the ‘box’ that is shown for the layer object is a bounding box (it looks like the bounding box of other objects), it is always exactly the same sized small square in the same position no matter where I try to draw to. I figure that if it’s just not rendering, the bounding box would change size and position at least to reflect where I had drawn…? But all it seems to do is create a layer and do nothing. Of course, that is just an assumption. I really can’t tell what it is doing.

It is worth noting that everything else, circle tool, spline tool, fill tool, draw tool, etc seem to work. They properly display and draw objects on the screen. But I just want to do some simple traditional animation. I’d use a program like Pencil2D, but using MyPaint brushes would be really sweet and I want to at least be able to animate and tween backgrounds, perhaps, and have more options available to me. I really want to get Synfig to work…

Thanks for the reply.


#4

Okay, I compiled synfig from source using the git master branch to see if I could get it to work. Now it came with 4 brushes. A 0.4 mm pen, a 0.8 mm pen, and what I assume are two erasers. Using these tools caused exactly the same error described here: Brush tool acting weird

I also added the mypaint brush folder so I could use mypaint’s default brushes. None of these brushes worked! So I think the problem I was having before was that a) no brushes came with synfig installed from the Ubuntu repositories and b) brushes from mypaint don’t work with it. However, the default synfig brushes do work (in the sense that they draw… something) Except, they work poorly and draw disconnected lines. Possibly related, drawing with the brush tool is really laggy.