Autosave doesn't


#1

My synfig crashes quite often, so it would be great if autosave would work so I wouldn’t lose so much work. But it doesn’t, and ~/.synfig/autorecovery is always empty.


#2

Have you checked the settings (preferences) to see if autosave is on…? ._.


#3

Menu Edit-> Preferences -> System -> Auto backup and don’t forget enter an interval. I use 60s when I’m drawing and 5s if I’m animating.


#4

Yes, of course I have Auto Backup turned on. (And before I wrote my post above I even turned it off and turned it back on again, to make sure it’s not a UI glitch.)


#5

Ah, okay, i see… :neutral_face:
What’s the Synfig version, by the way?
It could be related somehow…


#6

Synfig Studio 1.2.1 on (k)ubuntu 18.10 (cosmic, 1.2.1-0.1build1)


#7

Have you tried the most recent version?
The most recent version atm is 1.2.2

Additional note, the autosave was actually broken in the version that you have, and it got fixed in v 1.2.2

See Synfig’s post here for more details and dl links


#8

1.2.2 isn’t available for any ubuntu, as far as I can tell. But I tried the 1.2.2 appimage and that seems to work well. I have no idea where it stores the autosave file(s), but upon relaunching the application after a crash it does ask to recover, and successfully recovers the project.


#9

I… actually don’t know either… :roll_eyes:
Maybe @ebarranko can answer it…

But at least it does work as it should be :bulb:


#10

This version is very recent for ubuntu repositories. I don’t think it’s so useful to know where the files are, they’re not commun files, and they disappear when you save or ignore the restore. In Manjaro linux are in:

//home/user/.config/synfig/tmp/