Aspect Ratio

Hey Guys,

I’ve got a project that needs to be 720x480 with an aspect ratio of 16/9. How to you go about changing this?

I’ve already set it for 720x480, that part is straight forward, but how do I change the aspect ratio so that it is 16/9?

Thanks in advance.

I am not very confident on this subject, but if I remember right 720x480 is NTSC (TV standard, aspect ratio 3:2). You can’t lossless convert it to aspect ratio 16:9 because it’s widescreen. If you attempt, then the resulted image will be squeezed and have black corners around it or stretched. In any case, the resulted video will look nasty.

If you plan to make your video look good on wide screen, why not using the proper standard from the beginning? The closest is FWVGA (854x480) it has the same height as NTSC but suitable for widescreen devices.

Well, to actually answer your question, I think you can’t set aspect ratio in Synfig because it depends on the resolution which you already set. You can convert your video after rendering using an appropriate video editor. I know Movie Maker can do this. But as I said, the resulted video will have unused space (black corners).

This synfig face is quite touchy … i have added some extra informations to the doc (resize and keep aspect section), please, check it… i think that will fit your question.

I tried changing the xres to 87, while leaving the yres at 72 but it doesn’t seem to take effect. If I open a still in the Gimp after exporting wiht these setting I still see that the image has an xres of 72, not 87.

Is this a bug, or am I doing something wrong?

The x and y res do not affect the size of the content … X and Y res values are used to estimate the physical size (if printed!) of the content.

Finally those values could/should be named ppi (or dpi) (or maybe simply removed?).

More information :

(nota : wiki updated)

I just installed RC3 hoping it would fix the issue, but I’m even more confused.

I created a new fil that is 16/9 by default. I change the image size to 720 x 480 but when I render it gives me images that are 480 x 270!!!

Seriously, how can that be?? I can’t change the image size? what gives? This seems like a major issue. I can’t even control the size of my video.

Please tell me there is a workaround for this, as it makes Synfig practically useless currently.

I can change the image size, but it doesn’t affect the output. Even if I save the file and open it again it reverts to its original size. This is a serious issue IMHO.

Please Can you reproduce exaclty this sequence :

  • open synfig
  • open the “canvas properties” (F8 or menu/canvas/properties)
  • In “Image Tab” fill : Width = 720 , Height = 480 (ratio 3/2) -> close with [OK]
  • draw something … why not a star?
  • open the “Render dialog” (F9 or menu/file/render)
  • “Image Tab” is already filled with Width = 720 , Height = 480
  • Filename “Synfig Animation 1.png” hit choose to select where to render , target is “Auto”
  • Check “Render current frame” (to not wait to much)
  • click [Render]

“Synfig Animation 1.png” is 720x480 … is’nt it ?

Yeah I tried it and it worked for 720x480

Now I need it larger (872 x 480). I tried to repeat the same sequence, but after changing the width to 872 and clicking OK… NOTHING HAPPENS!!

it reverts back to 720! I can’t even change the most basic of settings :frowning:

I change the image width, hit apply and it DOES NOTHING!!

seriously, this is a pretty bad bug.

I’m on OSX btw.

Also, I can’t select more than one layer now. So creating a group from multiple layers is impossible. I have to select one, create a group and manually insert the other layers one by one.

I hope you guys can fix this quickly :frowning:

I succeeded, after a lot of work. I change the image width in the canvas properties, then had to change it AGAIN in the render dialog.

It seems to work, but it’s not intuitive at all.

Setting the image size for new documents seemed not do work. I had to change it in the current document as mentioned above. Hope this helps clear up the bug.

Again with the same problem. I change the image width to 872 in the render dialog and it exports 856!!! How is this possible?

It’s so difficult to work with right now. I hope you can fix this.

I change the image width to 872 for new files and it DOES NOT WORK. So I change it manually in the Canvas properties and it SEEMS TO WORK but when I render it ouputs to 856 EVEN IF I CHANGE IT AGAIN TO 872!!! This is the weirdest and most infuriating bug I’ve ever seen in a program. I cannot control the output of this version of Synfig!!!

Ubik, please file up a bug issue on the tracker because it seems to be related to OSX only.

Ok I’ll look into it. Thankfully I have the linux version on the side :wink: