Appleman1234's Attempts at Building Synfig

Hi everyone.
I am trying to compile synfig on Gentoo ~x86 (unstable x86).
Currently 0.61.09 from ebuild doesn’t compile
Currently 0.62.00 from ebuild doesn’t compile
Currently git current from ebuild doesn’t configure
Currently 0.62.00 from source doesn’t compile.
Build logs and emerge / system core package info is attached.
Managed to get the source and ebuild build logs for 0.62.00 to match up by removing -ggdb from my CFLAGS, so I think that the synfig ebuild / make is incorrectly parsing cflags as command line arguments, but both still fail at line 88 of Distance.cpp where strscanf isn’t defined inspite of ETL being installed and defining it and that line 66 has the same call and it finds it there.
Trying to build git from source now.
ETL 0.4.13 is installed successfully as are other dependencies.
Thanks for any help or advice.
emergeinfo.txt (5.38 KB)
buildnonebuild.log (22.1 KB)
build-9999.log (50.6 KB)
build-0.62.00.log (42.9 KB)
build-0.61.09.log (608 KB)

The 0.61.09 version build log is unintelligible and being an old version better just forget about it.

From the 0.62.00 version build log, I think the problem is in your CFLAGS.
The CXXFLAGS that configure reads are ‘-march=prescott -pipe gdb -DNDEBUG -O2 -W -Wall’
Take out the “gdb” and should work.

From the build from the source, did you compile again the ETL included?

I have updated the ebuilds for both 0.62.00 and live versions with a fix that rubik’s cube posted in bugzilla.
Try adding these new ebuilds to your local overlay and compile them. (sunrise 0.62.00 ebuild isn’t fixed yet)

Hope that it helps.

When I removed the -gdb , it still failed to compile, complaining line 88 of Distance.cpp had strscanf not defined.

I have tried to compile from GIT, but synfig-core still has the same error with old ETL, and it can’t find the new (git) ETL in its configure.
I will try reinstalling ETL.

After reinstalling ETL from ebuild that wasn’t from sunrise, and then modifying synfig doins examples section, synfig-0.62.00 now builds :slight_smile:

It sounds like a ETL version problem.
Have you got the ETL-0.04.13 installed with the ebuild from sunrise or bugzilla?

The ebuild does the same as the build instructions in the wiki (script posted at the end) (which I assume you use) so both ebuild and git builds should (and they do for me) compile perfectly.