Anyone (apart from pabs) tried build 2377 yet?

I’m having problems - I’m getting ‘no rule to make package’ - no rule to make etl_profile.h - needed by all-am.
but I see a line in ETL/ETL/makefile.in that references etl_profile.h…

Thoughts anyone?

Chris

I’ll run my standard build script this evening and leave here the results.
-G

Can you post the full build log?

Same problem here… (on Debian 5)

G.

Did you regenerate the autotools stuff? Just running autoreconf should be enough.

I’ve done the following:

For ETL:

svn co https://synfig.svn.sourceforge.net/svnroot/synfig/ETL/trunk/ etl cd etl autoreconf --install --force ./configure sudo make install cd ..

and get this result:
pastebin.com/m25180186

For synfig-core:

svn co https://synfig.svn.sourceforge.net/svnroot/synfig/synfig-core/trunk/ synfig-core sed -i 's/^AC_CONFIG_SUBDIRS/# AC_CONFIG_SUBDIRS/' synfig-core/configure.ac cd synfig-core libtoolize --ltdl --copy --force autoreconf --install --force ./configure make -j8 sudo make install -j8 cd ..

NOTE: the sed command is to solve the problem with libltdl in Ubuntu.
and get this result.
pastebin.com/m4ed2ea07

It has a lot of warnings ad finally it doesn’t compile.

Are your errors similar?
-G

Doing the same but with the previous commit (2376) I have those results:

For etl:
pastebin.com/ma88547d

For synfig-core:
pastebin.com/m241fd43d

It builds perfectly in the previous version.

-G

I don’t get genete’s error, but it should be fixable by changing #include “etl_profile.h” to #include <etl_profile.h> in ETL/etl_config.h.

For me, ETL already fails…

ETL$ make install Making install in ETL make[1]: Entering directory `/home/gerco/src/synfig-clean/ETL/ETL' make[1]: *** No rule to make target `/etl_profile.h', needed by `all-am'. Stop. make[1]: Leaving directory `/home/gerco/src/synfig-clean/ETL/ETL' make: *** [install-recursive] Error 1

G.

Could you attach your ETL/Makefile, ETL/Makefile.in files?

It appears the $(builddir) is undefined…

Makefile.in: pastebin.com/m629b9b51

Makefile: pastebin.com/m4698d06f

G.

I see the same error as Gerco.
Chris

Ah, automake 1.9. What happens if you change $(builddir)/etl_profile.h to etl_profile.h?

I have automake 1.8 (I think). I tweaked the Makefile.am in the ETL/ETL dir to delete the $(builddir) and things seem to be much happier.

Edit: Yay! 2377 successfully built! Can you submit that change pabs?

I had same problem building synfig-core like genete.

Changing #include “etl_profile.h” to #include <etl_profile.h> in ETL/etl_config.h helped. Thanks!

I think that first has to be solved the windows build and then see if the modifications for windows build allows build to the rest.
Pixelgeek, can you submit a patch of what you did to successfully build?. Please use review board.
Others can apply it and see if it is solved or need more modifications.
-G

Well - it’s kind of at patches.synfig.org/r/28/
I can’t get the path to work correctly so that the diff works properly.
Just in case you can’t understand what I did, I paste it here too…

[code]Index: ETL/Makefile.am

— ETL/Makefile.am (revision 2377)
+++ ETL/Makefile.am (working copy)
@@ -6,7 +6,7 @@

etlconfigdir = $(libdir)/ETL/include

-etlconfig_DATA = $(builddir)/etl_profile.h
+etlconfig_DATA = etl_profile.h

etldir = $(includedir)/ETL

[/code]

Pushed both of the patches into the SVN repository.

I can compile again!

G.