A preview error

I am having trouble previewing the animatics that I am doing. First, I would like to say that I am importing png files only for the animatic part for now. I have them set up so that each one is shown at a time to reduce slowdown when I render, or preview it.

Anyway, whats happening is that when I preview my work, it doesn’t preview the whole thing. It just stops, even though I command it to go further. When I say stop, I don’t mean it crash. It like stops at a frame and the text in the command prompt goes nuts. Its says something like bad…something, i would have to look at that. When I try to preview again, it crashes.

But this time, I get an pop up error that goes says:

Glib-ERROR**: gmem.c:106: failed to allocate 1029016 bytes aborting

If i can get what the command prompt says, I will type that here as well.

Hi Eric,
I don’t remember your computer specifications, can you remind me?
It looks like you have memory troubles. 1029016 bytes is about 1MB that is a reasonable amount of memory to be able to allocate.
Meanwhile, reduce the render zoom in preview to make image size smaller and so need less buffer memory for each frame.

my specs are:

Windows 7 Home premimum
Intel R pentium R cPu G620 @2.60 GHZ
8182mb ram
DirectX version 11

I did what you said and it worked fine. =)

But now I’m having another problem :frowning:. It refuses to let me import any more of my .png files that I need to finish this animation. I was hoping to finish the animatics this weekend.
stressful warning.png

Looks like you moved the place of the sifz file or the location of the image file it loads at start up. Please recreate the situation of the relative position of the sifz file and the image file to fix it.
If you don’t success. Please do this:

  1. Do a backup of your sifz file.
  2. Rename the sifz file from “Actibots ep1 s1.sifz” to “Actibots ep1 s1.sifz.gz”
  3. Using 7-zip or any other file compression software extract it to “Actibots ep1 s1.sif” file.
  4. Open the sif file in a text editor and fix the path of the parameter filename at the line 21570

Use a text editor that supports long text files.

If it doesn’t work, please post here the file to allow me fix it.

I didn’t move anything before this began to happen. I tried to do what you said as well about putting them back where they were (after temporarily moving them), but I kept getting the same results. What’s odd about this is that it loads my previous .png files with no problems, but it will not let me import anything else. I get this red circle with a - and it tells me that i can’t import it with no reason why.

I really tried to do what you said Genete, but I could not get it to work. I tried 7-zip, used gedit to look at it, but I don’t know where the 21570 line is. I figured it was the last line since that was the last thing I did since it was the last thing I’ve imported. Nothing is numbered. All in all, I don’t know what I’m doing… If you would help me out, I would appreciate it.

Edit: I tried changing the name of the file i attached, but that didn’t work. Also, I’ve tried importing .png files to “Activots” in different locations and it imported fine. But this is a problem because it will not load previous .png files that I added and timed, which is a huuugge problem because there is a ton of them. It seems to have something to do with where the .sifz is located.
Activots ep1 s1.sifz (25.8 KB)

Nevermind. Forget about this because I’ve give up. I spent half a day trying to start over from scratch, but again, it refuses to let me import when i get to a certain number of imports. Maybe around 60, it doesn’t let me do import anything else. If it did the same thing this time too, then it will keep happening. It’s too stressful to keep trying.

Thanks for trying though. Really appreciate it.

It must be a problem of memory handling. Each imported image file needs to store it in memory to display on the window.
Anyway, I couldn’t fix anything unless you provide the sifz file and the png files that are referenced inside.

Okay, I’ve cooled down, and gave it another go. This time, I’ve deleted alot of my imports and tried to add new ones. It didn’t work. Luckly, I made a backup. :slight_smile:

I tried to put the zip folder here with the animatics, but it was too large. Do you have an email address?