A bit of a desolate state on Debian testing


#1

Yesterday, I decided to give Synfig a try and installed it on my Debian testing laptop (no Desktop Environment, but multiple graphics applications working fine).

First I’ve installed Synfig 1.2.2.-1+b2 through the official repositories (apt install synfig).
The first issue was, that aptitude,installs synfig without automatically adding synfigstudio to the list of software to be installed. I don’t know what’s the use case for installing synfig without synfigstudio (a render farm?) but – in my eyes – synfigstudio should be a suggested package. One that is automatically added to the list of software to be installed (and can be removed if the user does not want it; many other packages have such suggested soft dependencies).
I’ve lost a few minutes looking for Synfig in the menus and then figuring out why the terminal was telling me that I need a cryptic list of arguments to use Synfig.
After some time I discovered that in the list of packages there was als Synfig Studio.
Other people would have removed it and tried a different software…
Yes, the official name is Synfig Studio but even Wikipedia and the domain name say it’s AKA Synfig

Following the beginners tutorial, I’ve tried to import a PNG: Synfig Studio crashes. Each time. And this happens with multiple different PNGs.
I’ve uninstalled Synfig Studio.

And got the development Appimage.
Started and nothing happens. After some time I’ve killed the process that was at 100%.
I’ve then tried to run the Appimage from the command line and see if there where useful messages.
It goes through all fonts, with several errors and then stays still.
I’ve left it there, to see if it had more to say.
Suddenly, a small about window pops up and short thereafter the SynfigStudio UI. It works and it’s snappy! And it can correctly import the PNGs.
But each time it takes three minutes to start! (I did not clock it… but it’s really long…)
(On this computer, I have Scribus trunk and Inkscape trunk as Appimages and both start in a matter of a couple of seconds.)

I can give more infos about my system if it can help solving the issues listed above…

Otherwise, the first steps were nice to go through…


#2

Hi and welcome here :slight_smile:
Thank you for your interest in providing feedback.

For the problem of .deb packages…
Each distro has a pool of maintainers creating packages from the sources.
It is not Synfig’s team, it is independant, the choice to include any lib or version is theirs.
They maintain according the evolution of their version and environment, which permit to provide “expected” stability.

And as each distro is different…
…there is the appimage version :wink:

Appimage permits to bring in a single package (mostly) all the required libs for the software, with the proper version.
As a drawback, it is bigger and need some install/decompression at startup.

The errors of fontconfig are known, it is because we use an older/more compatible version of the lib which doesn’t recognize new information format in the font file description, but no consequence on runtime.

Depending on your installation, you may need to set permissions on /tmp directory, use appimaged daemon…
If there is a problem of permission, the cache can’t be writen properly for example, it could explain why it needs so much time (recreation of font cache?)
And it depends if you use 1.2.2 or a later version (appimage format may be different)

:wink:



#3

Hi Bob,

  1. you might want to onboard the .deb maintainers. their packages are probably used by debian, ubuntu and several other distributions.
    I’m active in another free software project and being able to talk to the debian maintainer has helped us a lot in the past and also is helpful to him since he gets his wishes through very easily (when they are doable)
  2. there is indeed a
    Fontconfig error: Cannot load default config file
    before the appimage hibernates.
    No further message is shown unti short beforel the UI is shown, next messages being (probably):
    synfig(21762) [10:09:10 PM] warning: Unable to find module "mod_mng" (file not found)
    synfig(21762) [10:09:10 PM] warning: Unable to find module "mod_openexr" (file not found)
    AFAIK, Inkscape and Scribus also use fontconfig and I don’t have any issue there.
    It does not seem to be a “basic” misconfiguration on this computer… but rather something missing in the appimage.

Have a wonderful weekend.
a.l.e