0.63.05 Problems.

Not too long ago, I upgraded 0.62.00 to 0.63.05 and gave it a try. The first thing I did was try out a tutorial on it, selecting the rectangle tool and adding a rectangle to the canvas … only it wouldn’t let me! Next I tried the circle, shape and polygon tools. Same thing! I couldn’t put anything on the canvas. I was tweaking anything and everything I could think of that might be causing the problem, but it was still messed up. Frustrated, I uninstalled 0.63.05 and put 0.62.00 back on. Problem solved.

Has anyone else been having problems like this with 0.63.05?

Software info: Ubuntu 10.04 Lucid Lynx
Hardware info: Toshiba Satellite L455-S5989

Hello and welcome,

Humm, pointing (mouse) problem in the canvas …
“Too bad” (??), you have already uninstalled 0.63.05 and “solved” you problem…

In your “tweaking anything and everything” process did you try to have a look to Synfig / Menu / File / InputDevice ?


But is there any layer created on the layer stack? Does the pointer follow the mouse?
I bet that the issue is the default blend method.
Please be sure that the default blend method at the toolbox is set to “Composite” or to “By layer default”.

The pointer followed the mouse, yes, but I couldn’t create a layer on the layer stack or the canvas.

I tried that, and it still didn’t work.

When I installed 0.63.05, it was from a .deb file on this site, not from the Ubuntu repositories where I get most of my stuff. 0.62.00 is the latest version currently available from the Ubuntu repositories. My guess is that their developers tried out 0.63.05, ran into the same problems as I did or something similar and thus decided against putting it in their repositories. At this rate, though, 0.62.00 ain’t broke, so I won’t fix it for now.

Does Caret menu>Layer>New layer>Geometry>Circle produce any layer at the layer stack?

I don’t remember if I checked that, but I did try something similar. I tried reinstalling 0.63.05 earlier today and was able to load a tutorial project I had started in 0.62.00 that had a bline on it. The bline was still there on both the stack and the canvas, but I couldn’t add any more layers no matter how much I tried. I also couldn’t select the bline on the stack. I just threw in the towel and put the older version back on. (-_-)’

Thanks for helping out as best as you can, but I think I’ll just stay with the older release for now. I see no point in fighting with the newer release to make it work when the older one does what I need it to do without issue. I’m still taking the tutorials to learn the ropes of Synfig, and learning the basics is hard enough.

It is a pita. :frowning:
Your feedback could help us to fix a problem that others might have and that is not easy to reproduce since it might be a combination of hardware and software.

Where can I download 0.62.00?


Well, I’m back, everyone, and I can’t believe it took me this long to figure it out. I now have 0.63.05 back on my puter. I went to File →Input Devices under the Toolbox and selected my mouse under the “Devices” menu. Now it works! I sure feel like an idiot.