[Workaround, <= 1.4.4] Synfig Studio refuses to open an image

Dell OptiPlex 9010, Windows 10 Professional running on 4.08 GB free of 208 GB, Synfig 1.4.4
When I click on FILE > IMPORT and select an image, nothing shows. No error message, and no image. I tried a large image and nothing appeared. I need help. (I am also a beginner so I do not know how to animate on Synfig)

Hi and welcome here :slight_smile:

What type of image? A .png?

I have the same issue. I have a new install of the latest version (1.4.4), but when I try to import any image file in any format, nothing happens after selecting the file and clicking import. No error is generated, but nothing is changed on the canvas and apparently no import has happened. Please advise what might be amiss.

@jpcwebb what is your OS?
If Windows, are you using this build? Windows builds updated for version 1.4.4 – Synfig

I just used the version from the website download link. If this one is different, I’ll give it a try.

so the version I downloaded and installed which isn’t displaying any imported graphics is one I downloaded from that same link only the other day, so I must be using the latest. Windows 10 BTW - build 21H2

Are you using an installed version or the ‘portable’ version?

Hello, you need to save the project, then the images will be imported!


I had the same problem, I thought that it is a bug in synfig. However, when I tried to save the project before importing images, it works !!! ( unexpected behavior )

Before I know this tip, I was using 2 alternatives: drag & drop and import sequence (then select only one image ) . Both works without the need to save the project.

1 Like

Hello Rodolforg

I am using the latest version of Synfig as I only installed it this week. I also am using Windows 11 Pro

I previously had problems with just using the ‘import’. Nothing seemed to happen however when I used ‘import a sequence’ it worked. (this was when importing .png files) Thanks @Ahamd :+1:

I was wanting to import .svg files as this was related to issues that I think were related to using .png. I am using photoshop and the pen tool to create my shapes for the animation. I exported the file to .svg

When I went to ‘import sequence’ for the svg file I got an error:
“Nothing Imported”- “Unable to import sequence” - "Cannot import file type ‘svg’. "/C:\ …..\images\vector-arm.svg

When I used just “import”. It created a group layer with the transformation dials, but there is no the layers inside the group. No matter how I scale, move etc I never see the imported file.

I made sure the project was saved, as I saw @Ahamd comment.

I tried making my photoshop file only having only layer when it exported (previously other layers were hidden) I tried changing the location of the .svg’s so they were in same folder of the .sfiz file

I did look in the forums for an answer to this but didn’t get a clear and obvious answer (at least for me anyway) I did see that maybe installing Inkscape to export the file to .sif may be a workaround?

I have not tried installing inkscape yet as I am more familiar with Photoshop.

Hello @Sprog99
This question and answers may help you.

Also, you can use File 》 open then copy paste the layer to your file.

Hello Ahamd

Thanks you,

I tried what you suggested, File Open but i received an error:
Unable to load “C:.….…\arm.svg”
Document not well-formed.
Line 1 Column 1 (fatal)
Extra content at end of document

Unable to open file

I did select ‘all files’ at the bottom when I did File > Open as it was only showing sfig files.

I don’t have the Python - Lottie plugin installed. I think I did download it but couldn’t work out how to install it and have not needed a reason to try again just yet.