Width Ducks bugged

As the title says, I have a bit of a problem with width ducks. It only started today, they worked perfectly fine before:
Essentially, every new width duck I create, be it the ones given automatically when creating a new BLine or by inserting them in the list doesn’t give any width anymore. It’s there, but the value always snaps to 0 or a bugged version thereof (1.#INF00…). Also, the bright violet “duckling” that controls the “width circle’s” radius disappears if I try to drag it away from 0.
I really have no idea where this is coming from. I took some screens and compiled everything here:

LINK

I’m still able to change the width ducks of BLines from older files, even add new width ducks for existing BLines, as shown in the bottom right of the picture; but if I create a new BLine within one of these files, it has the same problem.

I really hope this is either known or a really simple bug which’s solution I overlooked while searching for an answer… Maybe it’ll solve itself.
Thank you in advance for any help you can provide.

Hi UFaction,
Do the following steps:

  1. Start Synfig Studio
  2. At the Toolbox, verify that the default with has a normal value (i.e. 5 pixels)
  3. Using the BLine tool, create an Advanced Outline
  4. If the problem persists, do right click on the purple duck of the widthpoint (pale purple) and select “Set width to default” from the contextual menu.

If the problem persists, then try to create a normal Outline and try to modify its width duck to see if the width duck vanishes when you try to modify it with the mouse.

Somehow, the modification of the width duck with the mouse gives a bad value result (infinite or not a number) and then the withpoint is disabled.

If for some reason you remove all the widthpoints from the advanced outline, go to parameters panel and right click on the WPList and select “Insert Item Smart” to add one widthpoint to the list.

Finally, if you still having the issue, try to save the file and I’ll try to load it on the Synfig Studio version I have for Windows.

Latest idea: At Windows hard disc, under the user’s folder, search for a “Synfig” folder. It contains the settings and preferences of the user for the Synfig Studio application. Please make a copy of it and allow me to have a look. In any case, delete the entire folder is safe to start Synfig Studio in a fresh way (maybe this solves the problem).

Good luck!

-G

Hi Genete!

That was indeed the cause of the problem, thank you!
I don’t remember changing the default width value though, is there some hotkey that changes the value that I could have accidentally pressed?

Also, I tried the “Set width to default” in hope of salvaging the bugged Advanced BLine I had, but it didn’t work. Not a problem, I can easily retrace it, but I thought you might want to know.

Should I still send you the settings and preferences?

Anyway, thank you again for the help, very much appreciated!

The default width widget is just a spin button with a distance value. There are many similar distance spin buttons all around in Synfig Studio so I don’t know what happened to it to produce that weird value.
Do you remember what did it display when it was buggy? It would have been interesting to know what caused it to fail.

Obviously, if the default value is buggy, that won’t fix anything.

No, not needed.

You’re welcome!
-G

Actually, I meant to ask if there is a hotkey that modifies the default value in the toolbox. Unless it’s the same thing.

The buggy value was 0,00pt, and I can recreate the bug by setting it to that.

I think that creating a BLine while having a default value of 0,00pt creates a bugged BLine, rather than the value in the toolbox itself being buggy.
Back then, I tried to reset the width while having a value of 5,00pt as my default. It didn’t correct the bugged lines, but I could create new BLines that work perfectly fine.

Nice bug!
Setting the default width to 0.0 triggers lots of problems! Thank you very much for raise it up. One more bug to fix, although I think it will be easy to solve it.

Could you please contribute with us and write a new bug tracker here?
sourceforge.net/tracker/?func=br … tid=757416

Cheers!
-G

All right, it’s done!
The tracker is registered as: N° 3560836 - “Default Width of 0,00pt creates AdvBLines with bugged Width”
I just hope I didn’t miss any important information among everything that was asked. I filled it out the best I could.

Anyway, thank you again for the help. I’ll be posting again once I finally get around to animating something!