Wacom won't draw in synfig (fixed)

I’m using a wacom Intuos3 4x6 on Windows XP using synfig 0.61.09 and its not clicking. I went to the FAQ and nothing there is helping me to get it to work as thats just for the tracking. Wondering if there is something that I have to use in synfig its self to get things working right. I tested this out in MSpaint and everything is working fine and I can still open folders with the pen.

Considering that it will be very difficult to have the same hardware than you to test the same error, please be more precise or do the following tests/questions:
0) Did it worked with synfig 0.61.08?

  1. Does it open the File Menu form the Tool Box?
  2. Does click on the Tool Box button work (ie. change the tool state)?
  3. Does it works with Gimp or Inkscape or any other GTK application you can install in your XP?

Try to go to the Device Settings… menu (using the mouse) and enable the stylus, eraser, etc. (everything that can be in the list) to be mapped to the ‘Screen’ (not window) and try again. Unfortunately the save feature is not enabled yet.

I’ve notice that the drop down list from the device setup dialog has changed since the introduction of GTK 2.14 so that can be the reason of not working.

-G

  1. Couldn’t get the tablet to work on linux and had 0.61.07 on it at the time.
  2. Yes
  3. Yes
  4. I downloaded Gimp because I will be using that as well and no has the same problem. Clicks won’t work in the work space, not even the wacom mouse will click on the workspace.

Should I just go looking for a patch and see if that works?

UPDATE: Went to the theme selector on Gtk and set everything to MS-Windows. Its now fixed and I don’t know how that fixed it but don’t care because now the tablet is working.

Good tip.

I had problems with a Wacom Cintiq 20WSX and the shipped CDROM drivers. Updating to the latest drivers on the web resolved the problems for me.