utility windows stuck on top

Gtk has a feature to make the utility windows stick to the front, over the canvas window. Is there a way to turn this off?
I found the synfig.org/Window_Manager_Hints page and I tried playing with ~/synfig/settings… synfig overwrites it when I start it

Errr, I’ve modified the setting file and it has not been rewritten.
Maybe what’s happening is that those preferences are not implemented yet. So when you close synfigstudio it writes the preferences that knows that has to be written but those aren’t in the known list of preferences.

There is code that “read” those preferences. But it seems that it doesn’t work at all.

I can play with the values when have some time :slight_smile:

Actully it doesn’t rewrite the file on statup, but while it’s running and when closing. But as you said, synfig isn’t reading my changes
Ah well…
Is there somewhere in the source where these preferences are set? perhaps I could recompile it

If you clone the git repository you can do a search on the code by using ‘git grep’.
Then do:

and that wiil show you in which files that string is used.

I’ve added a bug tracker for the macro that tries to parse the preferences entry and modify the windows hint value according to it.
That macro doesn’t work. I wish to look at it but it is not in my priorities now.

Thanks so much Genete! Perfect

For reference, the files in question were:
just find the lines with WINDOW_TYPE_HINT_UTILITY and replace with WINDOW_TYPE_HINT_NORMAL