Unicode Problem [SOLVED]


This bug has been fixed in Dev Version 1.3.4 (or 1.2.1 in Stable Releases)
Totally recommended to update to that version for a quick fix
And the fix for ‘jumbo’ interface will be arrive in Dev Version 1.3.5 (most likely)
Thanks in advance!! :smiley:

Hello again! :slight_smile:

I got another annoying case here.

Is there any way to make the unicode text shows up properly (like Japanese texts for example)
I tried just now and it doesn’t work. It just shows up some random A’s and boxes.

I also did a search on forum and found out that turning on cairo render will fix the issue. And it does, even in most recent version.
synfig.org/forums/viewtopic. … it=unicode

But considering that cairo render development have been stopped (and it has some issues with skeleton layer), i have to find another way to do it (without changing the renderer to cairo of course)

Is there any other way to do it ?

Import text from Inkscape and use them as shapes, not text layers.

Thanks for the tip. But i just tried that and can’t get it to work. :frowning:
But that’s probably because i couldn’t get your solution (and you can already from there tell that i’m new to inkscape as well) :blush:

Here’s what i just did.

  1. create a unicode text (in my case, Japanese text) by the text tool on inkscape, save as normal format (.svg) and import it to synfig studio
    result : file imported as blank group

  2. same as above but exported the file to .sif directly from inkscape
    result : still blank group

  3. still the same step but file exported to cairo png (.png)
    result : it does work but the “white paper” got carried away with it. Probably because i didn’t put the lower layer to alpha (i was in hurry to test it)

I used the Microsoft IME input to type the text

Am i not supposed to use the text tool or i have to convert the strokes to vector shapes first ? (even if that possible i still don’t know how to do it)
I wish i could though, so i can resize the text without getting worried with the broken pixels, which find often when resizing the bitmap images to a bigger size :neutral_face:

:unamused: peace :cry:

Do not import SVG directly to Synfig. Use the SVG2SIF plugin from Inkscape.

Just tried that and the result are still the same (blank group).

As far as i could find out, the SVG2SIF extension (downloaded from Scripts and tools in synfig download page) will add .sif file extension in “save as” option in inkscape and you can make the processing faster by preparing it for the export.
wiki.synfig.org/Doc:Svg2synfig#I … _extension :neutral_face:

In the most recent stable inkscape version (o.91) you can “save as” directly to .sif file. But i already tried that (see number 2 on my last post) and it still doesn’t work. :blush:

What are the differences between cairo render and normal render in synfig studio and why it can render unicode text while the normal renderer can’t ?
Also i wonder why cairo render’s development stopped… :unamused:

Okay, got it!!! :smiley:
I finally did the trick properly, in a different way. :wink:

[b]After i create the text in inkscape, i select the text and convert it to paths by shortcut (shift+ctrl+c) or from the top bar (object>path>object to path)

Then save as .sif (NOT .svg because it’ll end up imported to synfig in a really horrible condition)

Inkscape’s “Grouping” is also useful to keep the spaces between letters equal before exporting. :bulb:
But you can edit it in synfig as well if you forgot to do so.[/b]

And it got imported properly, save and sound. :mrgreen:

:smiley: Cheers 'n Love :slight_smile: !!!

Oh wait…
That’s what you actually want me to do !!!??
And i just found that out now!! :blush: :blush: :blush:

Almost forgot to put that on (Solved).
Well, at least this is a good workaround until the new render engine is ready. :wink: