Unable to load document (solved)

Hey, everyone,

I was trying to access a file I’d been working on a while back, and got the following error message: Unable to load [long file path here]

[file path again]/RumbleSynJointsandlayers.sifz::46419: error: is missing link 0 (item0000)

Now, I didn’t have any external files linked to that scene, as far as I know. The file itself should be just a character with some layer switches set up. It was imported from Inkscape drawings, then some additional copies and adjustments of layers were made in Synfig. The files weren’t linked, but there are some values within the file that are connected/linked. My best guess is that I converted a value to ‘average’ somewhere that I shouldn’t have, but now I can’t access the file at all, so I can’t fix whatever it is that’s wrong.

More worryingly, I don’t know what caused it. I’m pretty sure I managed to open it just fine before, and whatever changes I made last time were minor, since it was going to be little more than a proof of concept. The file was going to be used for tutorial purposes, and specifically on how to make custom switches for layer switching and skewing and alternative rigging methods. My point is: if the error is related to those switches, chances are the same error is going pop up again. I have also copied this file to a hard disk in between last time I opened it and this malfunction, not sure if that would make any difference.

I don’t mind starting over on it that much, because there were some tweaks that needed doing on it, but it’s still a good few hours of work lost and I’d very much like to know how to avoid this in the future. I’ll try to work back up to where I was in the meantime, and start saving before and after every session, I guess, and make sure the files open once done.

The file is attached below, if that helps anything. I’m also running it on Ubuntu. Would running it in Windows make any difference to this error?

Thanks in advance.
RumbleSynJointsandlayers.sifz (80.3 KB)


I’ve corrected your file, seems OK now.

From my experience, it happens sometimes. I once set a very big value of zoom and saved it, but re-loading it was impossible. Anyway, to be able to fix it in the future, you will have to rename your file to .zip, unpack it and then edit the file with your favorite XML editor.
RumbleSynJointsandlayers.sifz (80 KB)

Many thanks, good sir!

I did try to rename it to a .zip, but then the archive manager couldn’t open/extract it properly. I’ll definitely look into XML editing, then.

Thanks again.

Hi. I came across similar issue. After crashing multiple times synfig decided it wouldn’t open the file anymore. Stating this same (error: is missing link 0 (item0000). So I zippe the file and exctracted it. Off course I had no idea what to do with it so I removed everything in between … starting from the line that supposedly caused the error. Well yeah. Now it says

Document not well-formed.
Line 1, column 1 (fatal):
Extra content at the end of the document

What is happening? I have no idea. It’s not a great loss as I’m basically just only playing around and getting to know basics. Still I’d prefer to keep my files openable :stuck_out_tongue: Link provided if someone cares to take a look. Thank you in advance!

online backup storage