Unable to installsynfig

Alright I tried installing synfig on my windows 10 64 bit computer. I ran the 64 bit windows installer then I got a NSIS error saying the file is corrupted. I read up on the NSIS error saying that it might be the file path so I put it in a folder that I made sure that it doesn’t have any “unallowed” symbols and I renamed the file to just “install” nope I got the NSIS error again. So i tried the 32 bit installer instead, same thing NSIS error. Please help.

Please be sure that you have downloaded the installer from the official download site and that you have checksummed it (MD5/SHA signature).
-G

Yes I have checked both those things

Hello FacelessTIger (and welcome here!),

I found that in the forum …


nsis.sourceforge.net/Why_do_I_get_NSIS_Error

maybe could help…

Hi FacelessTiger,

there are several possibilities if your installer is not corrupted (= hash is ok)

  • try to start it as administrator
  • try to change its compatibility mode to a version prior to Windows 10
  • try to deactivate your antivirus
  • try to move your installer to an path without space prior to start it. Sometimes it is preventing a .msi to start correctly.
  • try to replace “Program Files” by “progra~1” (64bit edition on 64bit system, or 32bit edition on 32bit system) [ or by “progra~2” for a 32bit edition on a 64bit system]
  • you could have a problem of access on temp folder or destination.
  • you could install it a VM with a previous version of Windows and then transfer it back to the host machine, everything is portable.

We should think about to provide a .zip/.7z version of Synfig :stuck_out_tongue:

its set to run as administrator so everytime I run it it has administrator permission.
I changed the compatibility to windows 8 (there isn’t a windows 10 compatibility yet so windows 8 is as close as I could get)
I deactivated both my windows firewall and my antivirus, same result.
tried it
Could i simply rename program files to progra~1 instead of replacing it, I have a bunch of folders in there.
maybe
I don’t have windows 10 pro since I upgraded from windows 7 home professional meaning I don’t have virtual machine support, trust me I tried.