Try to link a bone to a group and I get "Cannot link two values of different types ('vector' and 'transformation')

I am trying to follow this demo: but am having problems. At first I tried doing this to a figure that I already created, but then had the error within the title. So then I basically tried creating two cheesy people like he had in his video, and I’m having the same error. Any idea what I am doing wrong?

You should try to link to its origin.

By it’s origin, do you mean the green dot? If so, this is what I am trying to do. I click on the green dot of the group, then the green dot of the bone (while holding down ctrl), and then right click and select link. I’ve tried both the bone first and the group first. Neither seem to work.

This bring up another question. I notice that most tutorials on bones have to do with warping a single shape (like a drawing of a character) and not for moving around groups of objects. Am I trying to use bones for the wrong thing? Should I just use rotation transformations instead?

You don’t have to select the green handle (yes, “origin” :wink: ) of the bone. Just right-click on bone after selecting the group origin.

In fact, AFAIK 1.4.0 complains about selecting the bone itself. IIRC it’ll be fixed on 1.4.1 (by ignoring the selection of parameters of bone itself).

That was it. I now see that “link” in the first menu was different than “link to bone” in the second. Thanks.