The eagle has landed.

Yah, hey dere! I’m a “newbie” to animation. I made my 1st ever animation using Synfig Studio v0.62.00 on a Linux Ubuntu laptop yesterday, following instructions from the wiki, then modifying it to make something more complex & unique. Even posted an AVI of the 2-second animation onto facebook. I was quite pleased with myself… Anyway, I was back at it tonight, reading the “User Documentation”, and worked my way through the “Adding Layers” page. But, I ran into something that simply wouldn’t work. Synfig wouldn’t let me change the blend layer’s method to be “Straight”! Any other method seemed to work, but it wouldn’t allow me to choose that option. So, I decided to come join this forum, in the hopes of gaining more skill w/ Synfig, and help when I run into problems like what I just described.

I just set my sig in the UCP, but it isn’t showing up here - so, I’ll add it in manually:

“These are the REAL people!”
(From “One Flew Over The Cuckoo’s Nest”)

Good to see you!

tell us what you are making right now?

Yes it is a known bug that unfortunately we don’t know yet how to solve it :frowning:
This happens for certain layers only due to an interference with other parameters. If the layer has other drop down menu (possibly the feather type) please change it to anything but the default value. Then try to change the blend method and if success then restore back the other parameter you changed.

Alternatively, before create your layer, change the default blend method to Straight on the new layers defaults on the toolbox.

Also, try to upgrade to use the 0.63.05 version. It has many improvements and bug fixes in comparison to the great 0.62.00 version.

Cheers and welcome!

Well, I’m still taking baby steps at the moment. My 1st original animation was based on the 1st tutorial example from the manual. I made it a bit more fancy by making the circle a face, adding a star, a background shape, and expanding the rectangle to full screen. I made the circle face, star, & background shape move from lower left to upper right & back w/ the face changing from frowning (left) to smiling (right). Yesterday, I managed to make a 32 second animation involving a rectangle & a circle. The circle went through phases of expansion & contraction from 5 pixels to full canvas & back w/ color changes correlatiing w/ max. & min. levels. The background rectangle just changed color once. It took several restarts of the circle layer to achieve, mainly because I needed to establish/learn that Synfig can’t do a gradual/animated inversion on an object. Today’s attempt didn’t get very far. I need to go read the manual some more.

Hi! Thanks for the reply. At least now I know it wasn’t just my inexperience. Hopefully, I’ll be able to remember the tips you gave me, the next time I run into that problem. (I’ve forgotten now, exactly what I was trying to achieve when I encountered this glitch.)

Unfortunately, I don’t think I can upgrade at the moment. I obtained & installed Synfig via the Synaptic Package Manager utility in my Ubuntu v10.04 OS, and v0.62.00 is the only version it has available. But, I’ve still got a HUGE amount of learning to do, before I get anywhere near outgrowing the version I have on hand.

My most pressing issue of the moment, is how do I limit the presence of an object in the animation? For example, if I want a star to magically appear at time mark 5 seconds & not be there before, and not be present after time mark 7 seconds, how would I achieve that? (I know the answer might be in the manual, & I’m working on it…) Another pressing issue, is how do I change the opacity of an object after it’s been created? And, can opacity be animated? That would solve my presence problem.

Anyway, thanks again for the reply. As Arnold is so often quoted as saying, “I’ll be back!”.

Maybe this reply to your two questions: … _a_blur.3F

“My most pressing issue of the moment, is how do I limit the presence of an object in the animation?”

That is your “amount” param. Enter animate mode, set amount to zero and frame 1 then set amount to “1” at 5 seconds. That will cause an invisible star to slowly fade in over 5 seconds. Or set the interpolation from “clamped” to “constant”. Then the amount value will go right from 0 to 1 without the fading.

Yes… there are a lot of terms to figure out in synfig! lol

Thanks, Genete! It’s nice to know that the “How To” section of the wiki is there.

Excellent, Michael! I think this solved the problem quite nicely. I’m going to try it out almost immediately, revising my 2nd animation to make use of this.

Update: Well, that wasn’t as easy as it seemed. I couldn’t find “interpolation” for the sake of adjusting it. However, understanding the “Amount” parameter allowed me to use it to make the star suddenly visible. Going into edit mode at frame 0, I set its amount = 0. Then at 31s26f, I set amount = 0. That cleared any previous animation of amount between those 2 points, and established a threshhold frame. At 31s27f, I set amount = 1. POOF! It was now visible.

Glad you’re progressing as you hoped.

“Interpolation” is WAY the values go from one to another, “ease in” “clamped” “linear” etc… You can change it on the tools widow before you make the object OR in the timetrack, those gold “diamonds” are waypoints made up of 2 halves… look at one. The front half is how the numbers approach the way point and the other is how they leave. Right click on there and you will be able to change these.

This might be a result of version, but I don’t have any “gold diamonds” on my timelines. Instead, I have round green balls w/ a very slight color difference splitting them into left & right halves. But, they seem to work in the way your “diamonds” are supposed to. So, I now have what I needed - a way to reset interpolation on the fly. Thanks!

Sounds right. Those circles are just a different interpolation. The gold diamonds are for clamped. Right click and you can change. U can also set the default on the tools window.

Aha! Gold diamonds = interpolation of “clamped”. Got it!