Text not showing at all - Mac

I’m trying make a start with synfig and have successfully animated a polygon with a gradient. However, when I add any text nothing is shown at all. I can see the handles but no text. Any ideas? I have tried both the stable and development versions of synfig - the screenshot shows version 1.3.13 (development) but it is the same with version 1.2.2

Hi JonathanB
What are the parameters of the group (text) layer ? (Opacity = 1 ?)

Yes, opacity is 1. I added it into a group due to another comment about this being a fix for some text issues but it makes no difference.

Strange… If you send your file .sifz, I can try to help !

Can’t post the file yet, but here is a dropbox link: https://www.dropbox.com/s/dgykgq3n7j44mdf/arrow.sifz?dl=0

Thanks.

I think it might be an issue with the software on the Mac though.

It opens fine on Debian Linux on 1.2.2 and 1.3.12

. + 1.3.13 on Lubuntu !

I just tried rendering and no text appears in the output file either. Looks like a MacOS issue then, will put an issue in on Github I guess.

Github issue raised - https://github.com/synfig/synfig/issues/1348

Invisible Text on Mac. Same problem as above with development version 1.3.33 on OSX – text is invisible with Text Tool. Default Sans Serif font generates only handles, no visible text. Tried entering Arial, no difference. Am I missing something basic or does Text Tool not work with OSX? Settings: Composite, Opacity 1, Size 15/15px, Orientation .5/.5, Depth 0; Family, tried sans serif, Arial, Debian Linux. Am new to Synfig and still learning, but having trouble with basic functions, like this. As mentioned elsewhere, Eyedropper tool doesn’t work either. Welcome all advice!

Hi: Still have trouble with invisible text. Using version 1.3.33 on OSX. Text box pops up, I enter text, handles appear, but I can see no text. I have tried different colors, ensured text was on top layer, tried different sizes of text, and tried entering names of texts available in OSX. Is this a known problem with OSX? Any recommended fixes? And it would be great if Eyedropper was fixed to work in OSX as well. Look forward to seeing next version of Synfig!

The file opens for me on OSX High Sierra. See screenshot below.

I’ve never had problems with text on all versions of Synfig on osx.

@scanlonjd @JonathanB

Could you please paste here what are the fonts you have in those two directories?
~/Library/Fonts/
/Library/Fonts/

You are absolutely right–was using font names off standard Catalina list on Internet, but when I use the full, precise font names from Library, success. Can’t cut and paste font list as the format not accepted here, but some examples, Arial Unicode.ttf, GaramondPro-Regular.otf, Cracked… I am not a coding expert, so steeper learning curve. Making progress–now having trouble importing PNGs–worked with GIMP, though low quality, but not other software. Again, thanks for continued support–made this basic video using Synfig Studio for background: https://www.youtube.com/watch?v=isXXNHRiU4E&t=3s. Dave S.

BTW, my Font folder, /Library/Fonts/, was missing many fonts, so restored from Font Book–appears to be a Catalina glitch. And, ~/Library/Fonts/ is an empty directory. I note the default text is Sans Serif, thus one has to enter a specific font–would be handy to have a drop down list–my son is a programmer, could he help?

“Sans Serif” is mapped to “arial”.
It would be good to have the font filenames to try to map them correctly.

Here are the fonts Catalina includes:

But I can’t know how the filenames really are by this list. And this is needed for text rendering.

Can you use terminal/command line on Mac?
ls -R /Library/Fonts/ may help :slight_smile: