[synfigstudio-0.62.00] Layers not displayed ... [solved]

Hello and thank you for developping synfig / synfigstudio.

I installed synfigstudio-0.62.00 on archlinux x86_64 a few days ago but I could not use it. I then installed synfigstudio-0.61.09, which is working fine.

My problem with version 0.62.00 : layers I try to create in the canvas window (like a rectangle, a bline…) are not displayed, and their ducks are also not displayed. They seem to be created nevertheless, since they appear in the history panel. When I run the preview, nothing appears (the preview window stays empty). The only visible thing I could create was a shaded background color, but the two-handle line supposed to configure this shading was not displayed. I could also import an exernal image but not resize it. However, I could open .sif / .sifz files found on the internet : they are displayed correctly and it was also possible to preview them.

I tried to tweak parameters in File -> Input devices, without success. I also tried to use the ~/.synfig/ directory from version 0.61.09, but it didn’t change anything.

Since I’m using KDE, I tried to launch synfigstudio in a minimalistic X environment (only a xterm) but the result was the same.

Since I’m using a french locale (fr_FR.utf8) I tried to launch synfigstudio-0.62.00 with LANG=C and LC_ALL=C but it didn’t change anything (except the language in the UI, of course).

I posted a bug report in the archlinux bugtracker (http://bugs.archlinux.org/task/16701?project=5) but I don’t have any answer yet.

I hope someone can help me on this forum. Version 0.61.09 is already great, but I would like to use the new one !

Please provide:
Information about where did you retrieve the package or if was installed from sources.
If installed from sources please be sure that you uninstall the previous version of etl, synfig & synfigstudio. Also provide step by step procedure you did to install it without omit any step. Be sure that you’ve installed etl, synfig and sinfigstudio in that order and with compatible versions.
Also a screenshot would be good. Please include layer panel, parameter panel, and history panel as minimum as well as toolbox and canvas window. Screenshots for previous loaded files and for new files with new layers created.

I guess that you’re mixing libraires versions so old files can be load with old libraries and new files are not displayed properly.

I installed synfigstudio with the archlinux package management system :

pacman -S synfig synfigstudio

etl was automatically installed as a dependency, before synfig and synfigstudio.
Here are the versions of the installed packages, with links to their respective PKGBUILDs (files describing how they’re build and installed on archlinux) :

These packages belong to arch’s “community” repository, which mean they’re maintained not by archlinux developpers, but by “trusted users”.

Here are the versions of installed etl / synfig / synfigstudio dependencies :

  • ffmpeg 0.5-1
  • fontconfig 2.6.0-2
  • gtkmm 2.18.2-1
  • imagemagick
  • libpng 1.2.39-1
  • libsigc++2.0
  • libtiff 3.9.1-1
  • libxml++ 2.26.0-1

All these dependencies belong to the “extra” repository, meaning they’re maintained by archlinux developers. They seem to do their job correctly, since other programs based on them work fine (eg. inkscape).

Two screenshots are attached :
The first shows that two layers (a circle and a rectangle) were created, but they don’t appear in the canvas window :

In the second screenshot, I opened a previously created .sifz file (created with synfig-0.61.09) ; it’s correctly displayed and the keyframe panel is also shown :

Thank you for your help.

What (x,y)-values do the control points have? Do they fall within the ranges of the canvas?


@Gerco : you intuition was right, the objects are created far outside the ranges of the canvas, and even oustide the canvas window, with (x,y)-values like -1294,xxx .
Using the Parameters panel, I could resize the layers and make them appear in the canvas window.
But even when they’re in the canvas, I cannot manipulate them by clicking on their ducks. When I click on a layer or on its ducks, it is simply deselected, as if I clicked somewhere else in the canvas. Clicking on it when it’s deselected doesn’t select it. It is as if the mouse pointer could do nothing in the canvas window… except creating objects outside it.
So far, the only way for me to manipulate layers is to set their coordinates, radius, etc., manually in the Parameters panel.
Here’s a third screenshot showing that I could create a rectangle and a circle and make them appear in the canvas window. The ducks of the circle are even displayed (I selected it from the History panel) but I cannot manipulate them with the mouse.

It appears there is some translation error between the actual coordinates of the mouse on the screen and the virtual canvas coordinates inside Synfigstudio. You seem to be using a 64-bit machine, which might very well be related, but also making it difficult for any of us 32-bit users to trace the problem. Have you tried compiling the Synfig sources yourself? If so, what were the warnings given by the compiler? Unfortunately, my knowledge of 32/64-bit compiling and compatibility issues is rather limited, and until I get my hands on a 64-bit machine, I’m not sure I can help you further.


I already tried to compile synfig and synfigstudio from source, but it didn’t solve my problem.

I just tried another time, with the same bug remaining :

  • I first uninstalled synfigstudio, synfig and etl
  • then I recompiled and reinstalled etl, synfig and synfigstudio (in this order).
    I used arch’s ‘makepkg’ utility, which automatically compiles and builds arch packages from source, following directions of the corresponding PKGBUILD file. I then installed these packages using arch’s ‘pacman’ tool.

I noticed that, on archlinux, synfig is built without libavcodec and libdv - I don’t know why :

./configure --prefix=/usr --sysconfdir=/etc \ --without-libavcodec --without-libdv
But I think it’s unrelated to my mouse pointer problem.

The only warnings I noticed when I compiled synfigstudio are related to missing libavcodec, dv and magickpp modules :

synfig(21796) [15:30:24] info: Chargement des modules depuis /etc/synfig_modules.cfg synfig: avertissement: Impossible de trouver le module "mod_magickpp" (file not found) synfig: avertissement: Impossible de trouver le module "mod_dv" (file not found) synfig: avertissement: Impossible de trouver le module "mod_libavcodec" (file not found)
(BTW, imagemagick is installed on my system, including /usr/lib/libMagick++.so, /usr/lib/libMagick++.so.2 and /usr/lib/libMagick++.so.2.0.0)

Here is a link to my compilation logs (from makepkg, including ‘./configure’, ‘make’ and ‘make install’ steps).

I recompiled synfig (and then synfigstudio) without this line :

--without-libavcodec --without-libdv

After compilation, libavcodec is still not found (like magickpp) but dv rendering is OK. It doesn’t change anything to my issue with the mouse pointer in canvas window.

As it has become clear that my problem came from the (x,y)-coordinates of the pointer, wrongly interpreted in the canvas window, I tried another time to change parameters in File -> Input devices. This time it worked ! I had to deactivate all proposed devices, including my Logitech USB mouse, and then the coordinates became correctly recognized. I’m surprised since I already tried to deactivate them all, without success - maybe the recompilation helped this time ?
Thank you for spending your time to solve my problem. I can now use synfigstudio-0.62.00 on my system.
BTW I’ll tell the archlinux package maintainer of synfig that it can be compiled with dv support.

That’s good to hear!

W.r.t. libavcodec, you need to actually enable it since it is currently off by default (I don’t know why). So, you need to add the “–with-libavcodec” option to the configure call, and it obviously should also be available and usable by configure/Synfig.


Thank you very much !
I just recompiled synfig with --with-libavcodec.
However I couldn’t have magickpp support even with --with-magickpp (this option doesn’t raise an error, but Magick++ is not found).
At build time, synfigstudio still complies for the lack of magickpp :

synfig(19931) [15:31:25] info: Chargement des modules depuis /etc/synfig_modules.cfg synfig: avertissement: Impossible de trouver le module "mod_magickpp" (file not found)
But, all in all, my problem is solved and I can work with synfigstudio-0.62.00.

The input device settings still being a problem in all the 0.62.00 I’ve seen for recent linux distributions.
After do the first journey of the synfig workshop in my town some pupils realized that they can’t see the the layers they produce. It is due to the fact that the input devices are by default set to active for the “Macintosh mouse button emulation” and for the “SynPS/2 Synaptics TouchPad”.
That produces that the layer are placed far away. Disabling them Synfig Studio works fine again.

Just for information…
On archlinux, xorg-server was upgraded to (1.7.2 RC 1) a few days ago and I had to change the settings in File -> Input Devices :* A new device was added to the list : “Virtual core XTEST pointer”

  • I had to set “Logitech USB-PS/2 Optical Mouse” as “Screen” instead of “Deactivate”.

So I guess that other users would have to change their settings when xorg-server will be updated on their systems.