Synfig with Wacom not working, or is it?

tablet

#1

So I sat down to learn synfig finally and cannot input anything with the Wacom pen. I can choose a tool, but on the canvas nothing happens (well the cursor + drags around). Ditto with pencil, or any other shape.

I grabbed my mouse and wa-la, circle.

So I searched and someone mentioned File>Input Devices in passing…

Pull up Input Devices and I have under WACOM Tablet Pressure Stylus X:1 Y:2 and none for the rest. I could not change any settings, using the mouse or the pen.

Then playing around while posting this I changed WACOM Tablet Pressure Stylus to Eraser, and Eraser from Disabled to Screen.
Changed back to Stylus item and now Stylus was disabled… changed that to Screen then Back to Eraser (still Screen) and back to Stylus:

Stylus is now “Screen”, the values X, Y, Pressure, X tilt and Y tilt are respectively 1,2,3,4,5 which I can change any of now (changing 3 to 5 swaps the values) and wheel is still none.

The pen draws now but I have NO IDEA what any of this means, why it wouldn’t change the values until I activated the Eraser and now what the values mean… ?! Can anyone explain the correct way to set up a stylus/pad input?

As a side, I’m guessing there are no pressure reactive tools… is that correct?


#2

Please report:

  1. Operating System
  2. Synfig Studio version
  3. Wacom tablet device type
    There are some threads on the forums that might help:
    Wacom not working under Linux
    Graphics tablet unresponsive to Synfig

-G


#3

Win 7 64 bit
Synfig Studio 0.63.04
Cintiq 24HD


#4

Definitely checkout - Graphics tablet unresponsive to Synfig

It’s the only way I can get it kick started.

Synfig does support pressure sensitive with Wacom tablets - make sure that you have the ‘pressure width’ option enabled in the drawing tool, and that your brush size is big enough to see the difference that it makes.


#5

Definitely a bug in the “Input Device…” dialog. It is not sufficient to check that the input device is correctly set, your tablet must be specifically chosen, even though it might already appear to be selected. This was the minimum action sequence that I found which would fix the problem (you can even do this with the tablet itself!):

Start Synfig
File, Input devices…
(note: “mode” won’t go to “disabled”, “pressure” is stuck on “none”)
select tablet, even though it appears to be selected already (note: “pressure” selection switches from “none” to “3”)
switch “mode” to “disabled”
switch “mode” back to “screen”

it works now.


#6

AndyCivil, is there any specific settings on the tablet itself that need to be changed in order for it to show up there (Noob question, got my tablet yesterday, plus not had a proper chance to look at the software)