Synfig Still Crashes

I haven’t been using Synfig for a few weeks, got busy and computer wasn’t working as well as it should have been. I went out and bought a new graphics card (nothing powerful but enough to get my 3D stuff working again) and some of the problems I had before are back again.

I used the code on this page and it still crashed. Because I just got a new graphics card I have been wondering if that is the problem or if there could be something else.

Also, its not animating what I have finished, I did the knight rider thing again to test things out and saving it to a gif. I open it under Firefox and it just sits there on the starting side but when i preview it, it moves. I am clueless right now and wonder if I should just break down and buy a new computer seeing as this one is about 4-5 years old.

I don’t think it is the new graphic card.
Can you provide the following information?:

-Operating system
-CPU, RAM, graphic card.
-Synfig version
-What was you doing when it crashed
-Can you reproduce the crash?
-If so, can you run synfigstudio from the command line and paste here the console output?
-Write down also the recipe to reproduce the bug if any.


Also did you compile it yourself?
And what’s your distribution/release (assuming Linux)?

As far as I understand Synfig, it doesn’t use the graphics card for rendering,
so that would be an unlikely suspect. I’ve also been using Synfig for a while
now on a hyperthreaded CPU on Linux, and it doesn’t crash under recent
revisions, so that’s not a likely suspect either (unlike under Windows).

Can you also upload the GIF? That’s a separate problem, right?


@ Genete
-Ubuntu 8.04
-pentium 4, 4gigs of ram, nvidia 7300GS OC
-Synfig version 0.61.07
-I was using the Bline to make the laser light show in the background for this one thing i wanted to do. Three diffrent colors dark outline with transparent inside.

  • Its not crashing now but still not able to render like it did before (thinkng Magic could be the problem)
    -zielvos@zielvos-desktop:~$ taskset -p -c O pgrep ssynfigstudio
    taskset (util-linux-ng 2.13.1)
    usage: taskset [options] [mask | cpu-list] [pid | cmd [args…]]
    set or get the affinity of a process

    -p, --pid operate on existing given pid
    -c, --cpu-list display and specify cpus in list format
    -h, --help display this help
    -V, --version output version information

The default behavior is to run a new command:
taskset 03 sshd -b 1024
You can retrieve the mask of an existing task:
taskset -p 700
Or set it:
taskset -p 03 700
List format uses a comma-separated list instead of a mask:
taskset -pc 0,3,7-11 700
Ranges in list format can take a stride argument:
e.g. 0-31:2 is equivalent to mask 0x55555555

That is all that I can give you right now Genete, it didn’t crash when I tried it again but it crashed 4 times before. I didn’t restart the computer or anything before I had to run off to work so stumped at what it could be now and why it crashed. I will start keeping a log of things if it happens again. I think that magic might have been uninstalled by accident but synaptic says I still have it on the computer. Imagemagik 7: is what is said to be there and not quite sure if I need anything else.


I didn’t compile it myself, I let synaptic do it and it worked fine before.
GirRave.sifz (1.5 KB)

uh! pretty old and buggy version!. We cannot give support for that version because probably the crasher has already been solved.
Try 0.61.08 or wait a little and get 0.61.09


Well, darn. 0.61.07 used to be stable for me on Ubuntu 8.04. Now that I’ve upgraded to Ubuntu 8.10 with 0.61.08, I get the start-up crash bug mentioned here: … bug/293414 . Manually building 0.61.09 probably won’t work for me since I’ve never managed to successfully build anything myself (including an earlier failed attempt at Synfig).So now I’m back to being officially without Synfig. :frowning:


The bug you mention in the post is already solved in the new release 0.61.09. It is not so difficult to build it as well as download the source code, untar it and run:

./configure make sudo make install

in etl, synfig-core and synfig-studio folders.

Just be sure that you have installed all the devel packages needed to build synfig.
Come on! it is worth to build it! :slight_smile:


What part of building Synfig from source is the problem?


mine just crashed, too! what’s the deal? i was in the process of importing a jpg image into synfig, and the program just up and crashed!

anyone know what the problem is?

Thanks in advance!


please give details of the exact procedure of what did you do to make the program crash. The operating System and the version of synfig you’re using.

Also is a good idea to start your own thread about a different issue than the thread of another poster what is related to a different issue in this case.

right! sorry, again (if you’ve read my last apology)!!!

ok, in answer to ur questions, my operating system is Vista (32-bit version!), the version of synfig is the latest (0.61.09), and what i was doing when the program crashed was simply zooming in (using ctrl and =), after having just imported jpg image into synfig, when the program just up and crashed!!!

ok, here’s the exact proceedure:

i opened Start menu, went to synfig in the menu…opened it!
went to ‘import’ in the File menu…selected the jpg image i wanted to import!
started zooming in using the buttons described above, and…the program CRASHED!!

does that help?

oh…and i tried it again! and that time it didn’t crash!!!

That crash when zooming in is a known bug: … tid=757416

ok! well…i hope someone comes up with a fix for it soon, then!!!

yes, i know what ur thinking!!! :wink: THAT SOMEONE COULD BE YOU!!!

like i’ve said before, though, i really don’t know HOW to fix those kind of things! i would like to learn, but not quite sure how to do it!!!