Synfig not working on macbook pro


#1

I’ve been using Synfig for a long time on a PC. I recently switched to a mac and downloaded the most recent mac version of synfig but when I try to install it nothing happens. It just won’t work. Any advice? I’ve tried all the obvious stuff like re-downloading and turning the machine on/off etc.


Installing Synfig on Mac OS X El Capitan 10.11.6
#2

Please report the OSX version and architecture used.
-G


#3

It’s version 10.8.2, not really sure what you mean by architecture though…


#4

Just in case it would be good to know if you were using a 32 or 64 bit version.

Currently we are not aware of nobody that have build and run Synfig Studio in a 10.8.x version. I have 10.7.5 and don’t plan to upgrade for the moment.
So it is difficult to debug any problem when we don’t have any way to run the application in that hardware and software environment.

I know that mountain Lion comes with Gatekeeper installed and configured to not allow to run any application that is not from the Mac App Store or Identified developers. Please try to tell to Gatekeeper to “Allow applications downloaded from anywhere”. It would allow to run applications from anywere so you must be more careful when downloading, install and run applications from non confident sources. In any case, modified versions (hacked) of legal Mac App store or Identified developers aren’t allowed if you select “anywhere”.

Notice that the default status for Gatekeeper in OSX Lion 10.7.5 is “anywhere”.

If after that it doesn’t run, I’m sorry, I can’t help more.

-G


#5

I just downloaded Xquartz and now Synfig opens but it won’t open any of my old .sifz files. Is it fair to assume this just isn’t gonna work?


#6
  • Does Synfig Studio show any error message when try to open your old files or what does it happen?
  • Which Synfig Studio package did you install (link to binaries)?
  • Can you create any animation when Synfig Studio opens? Can you save it and load it back in other session?
  • Can you share any of the files that doesn’t want to open in your Synfig Studio system?

-G


#7

Hi Genete,
I take over this subject because I guess I have the same problem : I downloaded the dmg file (synfigstudio_0.63.05_i386.dmg) from the official website and when I try to launch it, all I get is the icon bouncing on the dock for a few seconds, and then it just disappears with nothing launched… :frowning:
I run on OS X 10.8.3 (Mountain Lion) so I downloaded the latest version (2.7.4) of XQuartz (which apparently replaces X11 for new OS versions), installed it (everything ran fine), then launch again Synfig, but nothing more happened…

Do you have any idea of what should I do to make it work ?
Thanks :slight_smile:

edit : I have a macbook pro too


#8

Try running synfig from a terminal. It may give an error message that you can post here.


#9

Try to restart the computer completely. Mac books doesn’t shut down usually until you force to do so. If everything goes wrong then try to re-install Synfig Studio.
-G


#10

I started with the Windows solution : reboot the computer and… I can see the blue haired girl certainly announcing it’s gonna work now !.. 8)
A strange thing is that XQuartz is launching at the same time and is the one active (white dot in the dock) while Synfig icon is not but it’s frenetically bouncing again (I guess it’s bouncing cause it wants its white dot too :slight_smile:)…
Well at least I can start using it !! Thank you all for your help ! :slight_smile:


#11

Hi Genete!

I have succesfully managed to build the latest Master and also your second cairo branch in osx 10.8.2 so it’s working here on an iMac i7 processor using the latest version of XQuartz
I have not tried the dmg install file of synfig, I have instead build it using this commands:

cd synfig/ETL
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
./configure --prefix=/opt/local
make install
cd
cd synfig/synfig-core
glibtoolize --ltdl --copy --force
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
export CPPFLAGS=-I/opt/local/include
export LDFLAGS=-L/opt/local/lib
./configure --prefix=/opt/local
make
make install
cd
cd synfig/synfig-studio
export PKG_CONFIG_PATH=/opt/local/lib/pkgconfig
export PATH=/opt/local/bin:$PATH
autoreconf --install --force
./configure --prefix=/opt/local
make
make install

Good luck with the new version!! :smiley:


#12

Thank you Ulrik for the build report. Similar to those are the commands I use to build my own binaries on Mountain Lion at iMac so I don’t expect that MacBook would work differently.
-G


#13

“READ WHOLE POST BEFORE PROCIDING” I know this is late, but if anybody runs across this post again, i had same error. I ran the /Applications/SynfigStudio.app/Contents/MacOS/SynfigStudio by terminal and found out that i was missing the /Library/LaunchDaemons/org.freedesktop.dbus-system.plist. So i did some digging and found this solution: I did the “Install MacPorts”,“Install Kdenlive” and “Post Install”. Then it worked, dont worry if you dont have Leopard or Snow Leopard (I did it in Yosemite), and the line “sudo chown -R $USER ~/Library/Preferences/KDE” in post install gave me error (directory not found), but i proceeded anyways and it worked.

If this doesn’t work you can make sure synfigstudios is in the aplication folder of your user, and run this command “chmod +x /Applications/SynfigStudio.app/Contents/MacOS/SynfigStudio”. if not leave a reply to this post.


#14

Hey, I know this is late as well, but I am very confused. I have tried restarting my computer, but that doesn’t work, and I don’t understand all of the computer code.

I got as far as installing MacPorts, but I can’t find how to install kdenlive without using computer coding that I don’t understand. Is there someone who can help me out? I don’t know anything about computer coding, but I want to use Synfig, because it seems like a great program… Maybe just where to use this computer coding?

Any help would be appreciated!


#15

I know I’m adding to an old post, but I thought this might be helpful for anyone running into the same issue on newer builds of Mac OS. I recently downloaded Synfig and could not install it at first. I realized the problem in Mac OSX at least, is to allow programs downloaded from anywhere.

However, this option is hidden in System Preferences Sierra onwards.

I found the solution at osxdaily.com/2016/09/27/allow-ap … atekeeper/

Basically, you have to run terminal and then reinstate that option in System Preferences. Here are the steps:

1.	Quit out of System Preferences
2.	Open the Terminal app from the /Applications/Utilities/ folder and then enter the following command syntax: sudo spctl --master-disable 
3.	Hit return and authenticate with an admin password
4.	Relaunch System Preferences and go to “Security & Privacy” and the “General” tab
5.	You will now see the “Anywhere” option under ‘Allow apps downloaded from:’ Gatekeeper options

The full steps for enabling and disabling this can be found in the link above.