Synfig Lagging Windows 10 Stable Ver. 1.2.0


I paid for the video tutorials, followed instructions (but using a character I made), and spent hours because program lagged. I didn’t know the playback would lag badly as well. I could only see three frames even on the preview. I also heard that it lags on Windows, and I couldn’t have known before it. I downloaded the stable version.

Here are my specs:

Processor: Intel® Core™2 Duo CPU T5250 @ 1.50GHz
RAM: 4.00 GB
System Type: 64-bit OS, x64-based processor

Is there something I can do? If I can’t work with the Windows version what are my other options? I draw but I’m a beginner animator and I find Synfig to be user friendly and have very good tutorials. I searched on Google and said Adobe Animate and Anime Studio Pro are top two beginner friendly softwares so I tried the free trials, but I can’t find good tutorials to be able to use them.


this config is something like 10 years old, it is surely a bit weak for Synfig.
Anyway you could surely improve performances.
What is your graphic card ? Are the drivers up-to-date ?
Did you try to blow the dust from inside ? (Intel CPUs throttle when to much hot).
Have you checked the performances profile ? (Config / Power options).
Do you have any crapware in memory ? (4 GB are quick filled)
Do you have sufficient Virtual Memory ? Defragmented the Hard Disk ?
Try to deactivate the antivirus when using Synfig.
Deactivate Telemetry Services.
Try to run Synfig as administrator and set affinity on one core only (in Task Manager)
Depending your version of Windows, you could add some startup parameter (MSCONFIG).

Or you could invest in a new machine :wink:

I’ll try to do the following :slight_smile:

I’ll try to replace my machine as well. Thank you for your help!

You are welcome :slight_smile:
Oh, as well, try to use the last Dev builds (1.3.3) instead of 1.2.0.
Despite the fact they are Dev build, they are often better :wink: