Synfig getting slower and slower. Help

Hi everyone,

The longer my animation is, the slower synfig studio becomes…I have enclosed my pc spec:

Sometimes, it gets so frustratingly slow that I can’t do anything… :unamused: ( let alone frequent crashes)

Any tips on how to make it run faster?

Thanks in advance

comp spec.PNG

Getting more memory in your computer won’t hurt.
As for Synfig. I am assuming that you have the latest 1.0 version of Synfig. If not then stop reading and download it now. :smiley: I can only tell you what I do to speed things up. If you are using a lot of high resolution pixel images then use low resolution copies to work with and switch them with the high resolution ones before you render your final animation and tick on low resolution in the canvas window. Try to limit cpu hungry effects and if you do have to use a lot of special effects then render them in a separate pass with transparency and composite them back together with another program. Try not to make your scenes to long. Better render shorter ones (if possible) and again composite them with another program. If you export svg’s from Inkscape then keep your drawings simple or better make them in Synfig, but again keep them simple. Using bones on vector images is faster then using bone distortion on pixel images esp on images with a high resolution. Switching to linux will speed up things also. In the windows version make sure to enable single thread only, switch of Cairo render and don’t try to play big scenes in real time in your canvas window. The preview button is my best friend.

Thanks a lot… :slight_smile:

I will try to follow your pieces of advice…You’re right I should make shorter scenes …As for Synfig …I use synfig 0.64…I will check if there is a later version…

Once again thank you for your help. :slight_smile:

One more very important tip. Any group or scene this not currently being animated on the screen should have it’s “amount” value (which is actually opacity) set to 0. It appears that Synfig will continue to render/animate anything that is not invisible even if it is not within the canvas screen area.

See this thread:

A tip for faster animation

A very good tip indeed…Thanks a lot… :slight_smile:

The low resolution tip from the previous reply also seems to work…I had never paid attention to it before… :blush:

I wonder if Synfig renders unchecked layers as well… :question: What do you think?

Right-click layer name in layers panel and select Disable Layer Rendering

Disable Layer rendering is ONLY for production render (movie or image sequence export). It continue being rendered on the canvas while it is being edited.
Uncheck the layer effectively makes it not visible and not active on canvas and also not rendered. It is as effective as set its amount to zero but quicker to set of and off and doesn’t produce waypoints in case you’re in animate mode.

Wow, I never knew that! :smiley:

I’m still discovering things after years of continuous synfig use!..ashamed but thrilled :smiley: :blush: :smiley:

Thanks darkspace :slight_smile:

I’m so sorry…I 'm not sure I’m getting your point Genete … :blush: :cry: …Do you mean disabling a layer doesn’t make rendering faster? If so should I delete the layer completely? I’m a bit confused now…

I replied to darkspace regarding to Disable layer rendering menu entry because it doesn’t disable the layer rendering on canvas, it is only for export to movie/image sequence.

Also I confirm that disable layer (uncheck the checkbox on the layer list) will disable it completely (on canvas and in all places) so it WON’T render it so it will increase render speed the rest not unchecked. It will be as effective as pbattersby mentioned in his post but easier to apply. Of course you can enable the layer back again when you need to view it and it will come back to canvas.

This way, putting the stuff in not needed to edit (and thus not needed to render) in a Group layer and disabling the group layer, would increase edition and render speed of your animation.

Obviously, final render will take the time it needs to render, but you can go to take some coffee meanwhile and invoke command line interface for such task.

Thank you Genete…It’s very clear now :smiley:

In short:

Disable Layer Rendering: Image will show up in Canvas but not when you render to file or movie. (no speed gain)

Uncheck Layer: Image won’t show up in canvas and will not be rendered to file or movie. (speed gain)

Keep your scenes short! Lol…

Thanks a lot…

You have all been helpful …I am really grateful :smiley: