synfig crash add text

When I add text in synfig it crashes.

Any idea?

Windows Vista:

Synfig Studio 0.62.00
Revision: 20091103
Built on Nov 25 2009
Built with:
ETL 0.04.13
Synfig API (006000)
Synfig library 47
GTK+ 2.16.0
GNU G++ 3.4.5

Synfig 0.62.00
GTK+ 2.16.0

Hi flag,
Text can be added by two ways:

  1. Using the Text tool.
  2. Adding a text layer.

Using the text tool would imply:
a) click on the tool
b) check and set up the tool options
c) click on the canvas
d) fill the dialog with the desired string
f) close the dialog

Adding the Text layer imply:
a) Go to Caret Menu>Layer>New Layer>Other>Text
b) it would create a new layer with the default text layer values (font included)

Can you be more precise and explain us where does it crash?
Can you load this file?
sampletext.sifz (554 Bytes)

It’s not my post, but I have the same problem (I never tried text before), so I think I can post here :blush:
I downloaded the attached file, and Synfig crashed as soon as I open it.
I have Windows XP, DualCore CPU, and the version of Synfig that you gave me, with “use only a single thread” checked.
With “text layer”, Synfig crashes immediately, as soon as I release the mouse button.
With “text tool”, I can make adjustments, the window to type the text opens, and that is when click on “ok” that synfig crashes.
Thank you :slight_smile:

At this point we need to know if synfig outputs any message after crash.
To be able to copy/paste the message please do this small recipe:

After that, please paste here ALL the outputs (since you typed synfigstudio until it crash)

Thank you Genete,
I have nothing to be added to the console at the time of the crash.
In the console, there are all the messages GTKIconSource, and then 2 lines “rendering in the same thread”, and its all.
All output is in attached file.
synfigcrash.txt (14.5 KB)

Hmm… I just did a test again… after cleaning up my system. Some viruses, Trojan, etc. with “spybot serach & destroy”.
Now, everything seems to be ok, after “Microsoft Sercurity Essential” removed a “ssh…” somthing Thread… Strange.

I still get some “rendering in the same thread” messages.
And one time it started up with some empty ICONS.

synfig studio – starting up application…

synfig(5356) [09:35:45] info: Loading modules from …/etc/synfig_modules.cfg
synfig(5356) [09:35:47] info: …/…/…/src/gtkmm/asyncrenderer.cpp:484 rendering
in the same thread
synfig(5356) [09:35:47] info: …/…/…/src/gtkmm/asyncrenderer.cpp:484 rendering
in the same thread
synfig(5356) [09:35:56] info: …/…/…/src/gtkmm/asyncrenderer.cpp:484 rendering
in the same thread
synfig(5356) [09:36:07] info: …/…/…/src/gtkmm/asyncrenderer.cpp:484 rendering
in the same thread

Thank you guys for the report.
Let’s simplify it a bit:
After open de CMD window type:
“CD c:\program files\synfig\bin”
“copy c:\pathtothesamplefile\sampletext.sifz .”
“synfig.exe sampletext.sifz -o sampletext.png”

without the “”. Notice the ‘.’ at the end of second command.

Then paste here the messages. All them. Thanks

Hello Genete,
it’s the same, nothing, just crash :frowning: :

Microsoft Windows XP [version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Administrateur>Cd C:\Program Files\synfig\bin

C:\Program Files\Synfig\bin>copy D:\Documents\Madeleine\Téléchargements\samplete
1 fichier(s) copié(s).

C:\Program Files\Synfig\bin>synfig.exe sampletext.sifz -o sampletext.png
synfig(5732) [16:12:25] info: Loading modules from …/etc/synfig_modules.cfg

C:\Program Files\Synfig\bin>

Flag, that’s a good thing!

Mad0 - I’m wondering if this is a Swiss/US language issue, but I don’t have any way to test it. :frowning:

Huh. Well, good news and bad news.
Good news/bad news - I have now seen this issue.
Bad News/good news - It stopped reproducing and I can’t make it happen anymore.

I did an install of 0.62.01 on a clean Windows7 machine. I ran Synfig and went to add a text layer. On typing something in the dialog box and hitting ‘OK’ Synfig just hung. No extra messages to the console.
I saw this twice.
The third time I started Synfig, I moved the windows around so that I could see the text input dialog side by side with the console. Entered some text and hit OK, and it worked. I don’t know what changed. (I don’t think it’s relevant that the windows were moved, but wanted to record it here.) My guess is that there is something in fontconfig that needs to be initialized, and once initialized everything is happy. Looks like C:\Users<user name>\AppData\Local\Temp\fontconfig\cache gets created at first initialization.

It might be interesting to see what would happen if Synfig was left running for a while in the ‘hung’ state (to rule out a long initialization) or to run another opensource program that uses fontconfig. Or maybe you just need to try 3 times to get it to work. If it is just an init issue, that would corroborate the findings that Flag had where it just started working…

The above suggestion helped me get it to work. It does seem (at least in my case) like it’s due to a long initialization time. Here’s what I did to confirm that this was the issue:

  1. I created the “fontconfig” and “cache” folders, since the C:\Users<user name>\AppData\Local\Temp\fontconfig\cache path didn’t exist past the “Temp” folder (Note: This may or may not be a necessary step. It didn’t seem to help, but it’s what I did and if the remaining steps don’t work, then it may in fact be the key.)
  2. Open Synfig.
  3. Open up Task Manager in a side view.
  4. Find “synfigstudio” (possibly “synfigstudio.exe”) in the “Processes” tab.
  5. Do nothing in your open instance of Synfig (let it “rest”) and note what its general usage numbers under “CPU” are.
  6. Add the text layer and do NOTHING ELSE in Synfig.
  7. Observe the CPU usage again.

If long initialization is the case, then you should see CPU usage raise significantly (for me, it went from around 0.5%, spiked to around 30%, then drop and hover around 15% until it was done). This will allow you to see that its doing something behind the scenes. I do this with the other Synfig processes (like rendering) where it’s bad about prompting you as well. After some time (a few minutes), the CPU usage dropped back to a lower number (around 6%). I looked back at Synfig and sure enough, there it was. Now when I add text, it appears (relatively) quickly with no issues.