Synfig can't open file

Hi everybody, nice to meet you all.

So I’ve been using Synfig 1.5.0 for a couple of months now, had a few crashes to the desktop but otherwise it’s been working fine. I’m working on a project and it’s up to version five now. I worked on it a bit this morning, went to work, and now Synfig can’t open the file. When it goes to open it I get a large vertical black bar on the screen. I can’t even open previous versions of the project.

I can still minimize the Synfig window so my desktop looks like this -

I’m running MX Linux 19.3 and have to pkill the program to make it stop.

Don’t think it’s the video card or anything, everything else seems to be working fine.

Any ideas?


This could be anything, from the video driver to a broken update of the system.
This could be a message box displaying a big amount of errors.

Is it the same with any Synfig project?
Did you you install updates or a new application recently?

Try to download Synfig 1.4.2 appimage and open (a copy of) your file with it.

Same thing happens in 1.4.2. Doesn’t seem to happen with any other project. Pretty sure I haven’t done any updates or installed any new apps. I did find however I can still open versions 1 and 2 of my project so I can easily get back to where I was.

I think it might have something to do with this - On version three I downloaded a svg file and imported it into my project. When I go to move something that’s been imported I always move it using the green center dot. Well I forgot it was imported, selected all the child vertices, and then tried to move it by dragging a vertex.

Every time I do this I get the “It appears you are trying to edit a file which is not open” message. Whenever I get this message I have to click the Cancel button like 80 or 100 times before the message box goes away. I think I have to click it for every vertex in the imported object but I’ve never counted it.

This can take a good three minutes of clicking so I always just pkill Synfig and restart it. I then move the imported object with the green center dot like I should and save the file.

This time I was working in the morning when I tried to drag the imported object by a vertex and got the message. I had to go to work so I killed Synfig and powered down the computer without fixing the project first. Is it possible when I powered down that a temporary file or a memory cache was cleared and something didn’t finish properly? I’ve done this error before but always fixed and saved the project before powering down.

Anyway just thought it might help.

Thanks for the reply! And thanks for creating Synfig, it’s cool man!

This could easily be a missing link error which stops files from opening. Also, the older versions being affected makes me suspect that something happened to the imported file. Double check whether your svg file has been moved, renamed, or modified at all and try restoring it to the original configuration if there are any changes.

Disclaimer: I am not a creator of Synfig. I did a bit of translation in french, a few debugging and a few additions to the code. I am mainly moderator.
The others devs have done a lot more than me :wink:

If you could share a problematic sample file, it would be easier to track the problem :slight_smile:

I’ll try uploading the files. It’s a farmer carrying a hoe, enid_model_5 is the main file and new_hoe is the imported file.

It says “New users cannot upload attachments”. I’ll post a bit more then do it. I’m already back to where I was on the project so it’s no rush.


Edit - Looking at this post - Most irritating one it appears I’m getting a list of errors except I can’t see the text and control bar. I found if I click where the closing X is I can close it and go back to Synfig.

It’s a spam prevention, I guess.

You can upload to a Google Drive/One Drive/Dropbox/file upload server and provide us a link :slight_smile: