SVG import

Hi. I’m really sorry to be a pain but I thought somebody might be able to help really quickly; I’m sure I’m being thick. I would like to import an svg file into a new project and keep the quality of the image. The image contains text and whenever I import the text (and other elements of fine detail) become blurred. After this I tried exporting to a high res png file and increasing the document dimensions (even tried the max of 10000!) and still no joy. What an earth is going on?
Thanks in advance if anyone knows the answer!

How did you import the SVG file? If it was done directly using “Import” form the Caret Menu it means that you used import as bitmap feature of synfig that uses the convert command from ImageMagick. If the import is not correct maybe it is due to a bad import from convert command and not from any synfig conversion code.

If you tried any of the converters (external applications) the render should be as sharp as any other render form synfig.


Seen … ook_bad.3F ?


Thanks for your replies guys. It makes a lot of sense now. The problem I’m having is actually doing the conversion! I’ve followed the instructions from the FAQs using svgtosif/svg2sif and keep getting segfaults (22545 Segmentation fault). The actual output from running the bash script is:

input : data/plain.svg
output: .sif
/usr/bin/svg2sif: line 4: 22545 Segmentation fault      /usr/local/bin/svgtosif $1
cp: cannot stat `data/plain.sif': No such file or directory
Conversion complete!

It seemed strange that the output was .sif (it did create a file “.sif”), so I’ve been play8ing around with the svgtosif program. I think the input to it should be two parameters, e.g. ‘svgtosif plain.svg plain.sif’ since if I do that I get teh following output:

input : data/plain.svg
output: data/plain.sif
Segmentation fault

Still, there’s obviously something going wrong in the program. Has anybody got any suggestions / experience with this?

I played with an earlier version (I don’t know if akagogo changed anything since the version I first saw). From the output you posted, it looks like the batch file is doing its thing correctly.

It may be a stupid question, but did you get any errors when you did the

./configure && make && sudo make install


It would also be interesting to see what happened if you tried running the executable without the batch file - i.e. put the svg file in a data directory under your current dir, and run the executable (not the script), then check the data dir to see if the sif file was created.