Strange behavior of Blend Method


I made a simple background for my animation, it consists of some png images with different transparency. But when I try to import them from Synfig it appears differently from other programs (like GIMP/MyPaint). Looks like Synfig double or even triple alpha from the top images.

I tried different blend methods as well as increasing/decreasing quality parameter (1…10), but nothing helps. Same thing In the preview mode (max. quality).

For details, see example picture below. It is set of png images that was rendered with MyPaint/Gimp (left) and Synfig (right, version 0.64.1): solid black (Alpha: 100), solid red (A: 8), solid white (A: 16), solid green (A: 24) and blue (A: 32).

So what I can do to make Synfig’s render more accurate?

Try and change the gamma settings. File/setup/gamma…

All right, that’s worked! Heck, I totally missed that setting.

But after I set the gamma to 1 from 2.2 all other layers have become very dark, so I had to manually adjust the gamma to 2.2 of some layers to make the background looks good, but that isn’t a big deal.

Many thanks for the solution!