SOLVED: Windows Version bug

Creating a spline in Linux version 0.64.1 is DIFFERENT (but conforms to the “Manual” on the wiki and tutorial page) from the Windows 1.0.2 version!

Under windows 7 32 bit pro, creating a spline with “create outline” and “create region” selected, does NEITHER. (in Linux, it works as advertised in the tutorial). pressing “create spline” (gears) does NOT create the closed loop spline with the stipulated outline and region filled in foreground color.

what gives?

Right-click any vertex and select Loop Spline from the given menu. Then click gears or choose another tool from the Toolbox and you will get a CLOSED spline. :smiley:

Maybe you think about the Draw Tool who have an “auto loop” option… behavior that should be translated for Spline Tool i guess ( … issues/930)

(if darkspace comment solve your issue, please add [Solved] has prefix of your first title post)

no, i indeed AM creating a closed loop spline.

when i finish drawing the spline, it shows all the spline points in the loop connected by fine lines then i hit “create”, switch to “transform tool” or “move tool”, and the entire thing disappears from canvas (the layers are still there in layer panel).

then i have to go to “Layers”; select the outline separately, and right click and say “create outline” and then it shows the outline in 10pt thickness as intended. but again, the enclosed region is NOT filled as it should be (and on Linux it works).

instead of nothing, it should also show the foreground fill color, . if i use the bucket (fill tool) to fill my spline, it shows “no layer here”.

When you create a spline with the Spline Tool make sure that the opacity in the Spline Creation Panel is set to 1. When it is set to zero you get a region and or an outline that only exists in the Layers Panel, but they will not be visible on the canvas and the region will not be active when you try to fill it with the Bucket Tool, hence the no layer here message, not even after you gave it an outline with the Make outline feature .

THANKS! You have hit the nail on the head.
my opacity WAS originally set at “1.00”. but this was the problem.

very interesting: when i set the “opacity” to 0.98 or 0.99, I get the result!
When it is set at 1.00…the whole spline refuses to show!!!

!! Anybody else having this?

My spline settings are:
“Create a Region Layer”
“Create an Outline Layer”
advanced outline
plant layer
gradient layer

Blend Method “Straight”
Opacity 0.99 (was 1.00)
Brush Size 10px
Feather 0px
Link Origins CHECKED
Auto Export UNCHECKED.

Thanx. does anyone else have this bug?
At least I can be confident of learning what i’m meant to be learning now in the wiki manual.

Blend Method should be set to Composite. Setting the Opacity back to 1 should work then.
More info on Blend Methods can be found here:

Thoroughly SOLVED!! Thank you all.