[SOLVED] Weird Rotation Behaviour

…even WITH Rotation Layer? :unamused:

EDIT: Solution if you have got strange rotation behaviour (in my case):
Copy your stuff in a completely new Project, this might reset some settings, which caused the weird rotation behaviour in my case.
I then could rotate via the group-transform-tools like expected :smiley:

Hello everyone :frowning:

I just didn’t find ANY solution for this little problem:

Even if I use a rotation-layer to rotate my hand-drawed vectors/areas and stuff, it WON’T rotate like expected.
The rotation seems to be three-dimensional around some weird axis, while I just want it to be like expected, around the origin of the rotation layer, but PLEASE, SYNFIG, WHY NOT just in the 2 dimensions I did draw my stuff?!

I followed this tutorial: https://www.youtube.com/watch?v=r-FSDouTUkk&list=PL295548721404B03B&index=5
However, my rotation simply does not work like explained in the video, I don’t know why, but it just rotates my stuff like this:

Original rotation position:

After rotation direction 1 (Yes, I only want to rotate the shovel):

Rotation #2:

You should see the “Out-Of-Ratio-Error”… It’s streched like hell and that’s just not acceptable…

This is my layer-menu-whatever-window…

(“Drehen” is german for “rotation”)

I really hope somebody can tell me, how to keep the ratio, when rotating stuff… That’s actually the point, which I could have asked in one sentence :open_mouth: :blush: :unamused: :laughing:


Synfig-Version: 1.02
Windows 10

Get rid of the Drehen layer in the Shaufel group. After you did that, just click on the Shaufel group and use the Group Transformation Widget to rotate the shovel. For more info on the Group Transformation Widget see http://wiki.synfig.org/Group_Transformation_Widget. In short ctrl-drag the green handle to set the origin of rotation and use the blue handle to rotate everything inside the group.

Thanks for the quick answer, I should have mentioned, that this was the first thing I actually tried, even before the rotation layer.
Same results.

Here I can even see the stretching on those ducks!!
Hope you can still help?

I tried following now:

It perfectly works if I start a new project…
so what did I possibly do wrong, that it automatically will stretch it in the other project?

I now tried to copy that flea into a new project. That actually worked…
wonder why,
but yeah, thanks !