[Solved] Segmentation Fault on import list w/JPG file

I was working through the Walking cycle demo (http://wiki.synfig.org/wiki/Walk_Cycle) in the Wiki when I encountered this crash:

synfig(5535) [02:51:14 PM] info: basename(curpath)=doug, Path adjusted to Projects/Animation/Walk/animation.lst synfig(5535) [02:51:14 PM] error: Importer::open(): Unknown file type -- jpg synfig(5535) [02:51:14 PM] error: Unable to open /home/doug/Projects/Animation/Walk/frame_01.jpg synfig(5535) [02:51:14 PM] warning: Unable to get frame from "./Projects/Animation/Walk/animation.lst" Segmentation fault

Just trying to import a JPG (instead of a list) creates this error (but no crash):

synfig(7283) [04:17:45 PM] info: basename(curpath)=doug, Path adjusted to Projects/Animation/Walk/frame_01.jpg synfig(7283) [04:17:45 PM] error: Importer::open(): Unknown file type -- jpg synfig(7283) [04:17:45 PM] error: Importer::open(): Unknown file type -- jpg synfig(7283) [04:17:45 PM] error: Unable to create an importer object with file "./Projects/Animation/Walk/frame_01.jpg"

The segfault should probably be entered as a bug, but I imagine this is because a required library is not on my system (and not in the Synfig dependency list). Does anyone know which library is needed?

I’m on a fairly new install of Linux Mint Rebecca 17.1 (based on Ubuntu 14.04). I’m also unable to import JPG into Pitivi, so I know it’s on my system. I’ve tried many different JPG library packages, but clearly not the right one!

I just upgraded from the OS package (0.64.1-2) to the latest Ubuntu on the website: 0.64.3-20141222.0 (amd64), but it still happens.

Thanks for an amazing program!

EDIT: I should probably say that I was creating the example by hand, rather than importing the example .sifz file (which only causes an error, no crash).

I think you only can import PNG format files in Synfig.

The error you show tell you that synfig doesn’t understand the JGP format.

So, export the files to PNG format. : )


That was my assumption, until I encountered the wiki’s “Walking” example. I converted the list & images to PNG & it works fine. I also loaded their fully-formed example and it fails, too, until I remove the layer that references JPG files.

So my guess is that JPG does work, at least on some systems.


Are you using Cairo (Preferences>Render)?
Cairo can’t display jpg, only png.

Hi rylleman,

Yes, thanks. I was using Cairo to render, so I unchecked that and it doesn’t “fail” to import JPGs, but it also doesn’t show them - it’s not a problem to convert them outside synfig.

I know this is off topic (and I’ll try to file a bug report later), but I switched out of Cairo because I’m trying a “Curve Warp” distortion of text, but keep getting “Error: Can’t invert current cairo matrix!”, plus bad distortions/artifacts & weird parameter values. A Google search only picked up the GIT code with that error msg.


Hello doug and welcome here …

Yep , has Synfig import of jpeg is based on “libjpeg”, i think i’ts system wide problem … Are you able to open jpeg with gimp ?

If that can help you, in my case (debian 7) i have both libjpeg8 , libjpeg62 , libjpeg-progs package installed (plus libjpeg8-dev for dev’)

HI d.j.a.y,

Thanks for the welcome! I’m really impressed with Synfig and look forward to learning & contributing more, once I get through this “application” rush. Yes, I thought I had all the JPEG libraries I needed on my system, I even installed the development versions (when I was compiling PiTiVi), but it doesn’t seem to matter. Part of the problem is related to the Cairo lib, like rylleman mentioned.

Here’s what I have on my system (from 'dpkg -l “jpeg” ', there are no “jpg” packages):

libjpeg-turbo8:amd64 1.3.0-0ubuntu2 libjpeg-turbo8:i386 1.3.0-0ubuntu2 libjpeg-turbo8-dev:amd64 1.3.0-0ubuntu2 libjpeg8:amd64 8c-2ubuntu8 libjpeg8:i386 8c-2ubuntu8 libjpeg8-dev:amd64 8c-2ubuntu8 libmjpegutils-2.1-0 1:2.1.0+debian-2.1 libopenjpeg2:amd64 1.3+dfsg-4.7ubuntu1

What about libjpeg62 and libjpeg-progs ?

I’m sure that it’s not related to cairo libs : synfig cairo render actually support only png images. The software render support jpeg/png/gif and others images formats.

Hi d.j.a.y,

That did it. synfigstudio needs libjpeg62 and for the system settings in “Render” for Cairo to not be checked in order to load JPG files.

I need Cairo for the performance (it’s too slow to work productively without it), so it’s easy for me to just convert externally to PNG.

Thanks for your help!

Glad for you ! Can you had a [Solved] at the beginning of the original title post ?

Done! I rechecked the original tutorial process with the JPG animation list and it works when Cairo rendering is turned off and the correct JPG system libraries are installed. Thanks for your help!

Shall put the original issue: SegFault when importing an animated JPG list while using Cairo, onto my bug list to report once my development crunch is over? It’s probably a low priority bug.


Every issue should be reported … thank’s for participating in that ! …

and yes it could be a low priority bug has cairo render actually suffer of someone working on … , at the same time; in any case a segfault should appear…so … medium/high priority in fact :wink:

Thanks. I’ll write it up and post it in the issue tracker sometime next week (at least that’s how my schedule looks, for now). --Doug