[Solved] Problem assigning shortcut to Save All action


I recently started to work with several projects at once (linked from one main sif file) and found that I need to create a shortcut for “Save All” action because the usual “Save” ignore modifications in other files.

I added (gtk_accel_path "<Actions>/actions/save-all" "<Primary>e") to the “accelrc” file, but it doesn’t work. Interestingly, Synfig seems to acknowledge the change and show the shortcut in the menu when no files opened:
But when you do open projects the shortcut disappears and does not work. Is it a bug or I messed up somewhere? I tried with Synfig 1.4.0 and Development version.

That accel shortcut has to be implemented in Synfig code for it to work. The file you modified was for existing accel code already implemented. I’ll open a feature request for this.

Feature request created here:

1 Like

Thanks for creating a feature request.
I thought that every action stated in accelrc file is already implemented and just needs to be assigned, was wrong.

Did you change it here?

<Actions>/canvasview/save-all ?

Did you remove the semicolon ; at line beginning?

1 Like

Wait, there’s another “save-all”, what? I didn’t notice it…
I tried to modify the second one and it works now, thanks! A bit confusing, but oh well.

To conclude, you need to add the following lines in accelrc in order for “Save All” shortcut to work:
(gtk_accel_path "<Actions>/actions/save-all" "<Primary>e")
(gtk_accel_path "<Actions>/canvasview/save-all" "<Primary>e")

I also tried without adding the first line and it still works, so not sure why it’s even there.