[Solved] - Ducks visibility shortcuts don't work

As said in the title, on win-xp version, keyboard shortcuts to toggle all kind of ducks visibility don’t work (those 1,2,3…)
But it works when toggling them in the menu (wich is much fastidious)

Someone knows how I could bring back those shortcuts ?

(Also the width tool, wich is told to work here synfig.org/Releases/0.61.09, actually doesn’t work… anyone else have the same issue on xp?! )

Works for me. Make sure you have the bline selected in the layer dialog - They won’t show if the layer’s not highlighted.
If that doesn’t work for you, try quitting synfig, then deleting the files in c:\Documents and Settings(Username)\synfig* (specifically the accelrc file which contains the shortcuts. Synfig should recreate it when it reloads.

The width tool does work, but the defaults are ridiculously small, so it looks like nothing is happening. Toggle the width ducks on, then select the width tool. Set the tool settings to something like growth 20, radius 500, then left click on one of the bline radius ducks. You should see it grow. click on the line between two points and you should see both grow. (Control click to shrink).

Not needed. Width tool will show width ducks and hide vertex and tangent ducks.

Thanks, you’re right the width tool actually WORKS :slight_smile: with the mouse it works perfectly, but with the tablet pen sometimes it works, sometimes it doesn’t. Strange.

But Duck visibility shortcuts still doesn’t work for me, with any tool, they do nothing (and I need them to edit more easily my shapes where there’s lot of ducks overlapping each other… )
I’ve tried removing accelrc, no change (and I’ve checked those shortcut are already written right in this file - the old one and the new created- but they don’t work here!)

Any idea?

I’ve found it! The problem comes from my keyboard is an azerty, and numbers need a shift to be used, so it doesn’t work directly (Numpad numbers don’t work for it )
So in win’ language bar I’ve set my keyboard as a qwerty one, then it worked!

But as I won’t leave this qwerty setting, it would be cool to have a way to change those shortcuts, or to find a good workaround.

(I’ve tried to edit accelrc and change those shortcuts but each time I do they turn back to default when I start synfig.)

EDIT: Finally I get it! It was because I had “Shift+Alt” set to switch input betwen languages in windows language bar, I removed it now it works !!! :slight_smile:

Ahah! Glad you figured that one out. I don’t think we would have figured it out from where we’re sitting.